summaryrefslogtreecommitdiff
path: root/sys-libs/glibc/glibc-2.36-r7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-10 12:04:40 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-10 12:04:40 +0000
commitf95eeaf7db6ca1bfbb34c05fdad9ed9bb603b1c8 (patch)
tree1648438f1ddf9c11ea7cc5f7825a8d19266f00a5 /sys-libs/glibc/glibc-2.36-r7.ebuild
parent27ecae7b5eb4c80903720ae76a54a68af3447c31 (diff)
gentoo auto-resync : 10:03:2023 - 12:04:40
Diffstat (limited to 'sys-libs/glibc/glibc-2.36-r7.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.36-r7.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/sys-libs/glibc/glibc-2.36-r7.ebuild b/sys-libs/glibc/glibc-2.36-r7.ebuild
index 4d0fecf5932c..8bb3e20062b4 100644
--- a/sys-libs/glibc/glibc-2.36-r7.ebuild
+++ b/sys-libs/glibc/glibc-2.36-r7.ebuild
@@ -26,7 +26,7 @@ PATCH_DEV=dilfridge
if [[ ${PV} == 9999* ]]; then
inherit git-r3
else
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
SRC_URI="mirror://gnu/glibc/${P}.tar.xz"
SRC_URI+=" https://dev.gentoo.org/~${PATCH_DEV}/distfiles/${P}-patches-${PATCH_VER}.tar.xz"
fi
@@ -111,6 +111,7 @@ BDEPEND="
sys-apps/grep
app-alternatives/awk
)
+ test? ( dev-lang/perl )
"
COMMON_DEPEND="
gd? ( media-libs/gd:2= )
@@ -119,6 +120,7 @@ COMMON_DEPEND="
caps? ( sys-libs/libcap )
) )
perl? ( dev-lang/perl )
+ test? ( dev-lang/perl )
suid? ( caps? ( sys-libs/libcap ) )
selinux? ( sys-libs/libselinux )
systemtap? ( dev-util/systemtap )
@@ -1018,7 +1020,8 @@ glibc_do_configure() {
# up a Perl from outside the prefix instead. configure will fail to
# execute Perl during configure if we're cross-compiling a prefix, but
# it will just disable mtrace in that case.
- ac_cv_path_PERL="$(usex perl "${EPREFIX}"/usr/bin/perl no)"
+ # Note: mtrace is needed by the test suite.
+ ac_cv_path_PERL="$(usex perl "${EPREFIX}"/usr/bin/perl $(usex test "${EPREFIX}"/usr/bin/perl no))"
# locale data is arch-independent
# https://bugs.gentoo.org/753740