summaryrefslogtreecommitdiff
path: root/sys-libs/glibc/glibc-2.34.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-03 06:47:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-03 06:47:15 +0000
commitfc2f1018fc323ef2c6572734a9b130427cba76a6 (patch)
treef834bdc9a67923ce75297c09d00d1e7b90791d26 /sys-libs/glibc/glibc-2.34.ebuild
parent162945d2a91899b637bbb9e163b406350de12906 (diff)
gentoo resync : 03.11.2021
Diffstat (limited to 'sys-libs/glibc/glibc-2.34.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.34.ebuild16
1 files changed, 14 insertions, 2 deletions
diff --git a/sys-libs/glibc/glibc-2.34.ebuild b/sys-libs/glibc/glibc-2.34.ebuild
index 0a5f70fd284f..f292dc31fc3b 100644
--- a/sys-libs/glibc/glibc-2.34.ebuild
+++ b/sys-libs/glibc/glibc-2.34.ebuild
@@ -1519,7 +1519,13 @@ pkg_preinst() {
if ! use crypt && has_version "${CATEGORY}/${PN}[crypt]"; then
PRESERVED_OLD_LIBCRYPT=1
preserve_old_lib /$(get_libdir)/libcrypt$(get_libname 1)
- cp "${EROOT}"/usr/include/crypt.h "${T}"/crypt.h || die
+
+ # Only copy if it exists; some people may have tiny embedded
+ # systems without headers: https://bugs.gentoo.org/802207#c16
+ if [[ -f "${EROOT}"/usr/include/crypt.h ]] ; then
+ cp "${EROOT}"/usr/include/crypt.h "${T}"/crypt.h || die
+ fi
+
else
PRESERVED_OLD_LIBCRYPT=0
fi
@@ -1555,7 +1561,13 @@ pkg_postinst() {
if [[ ${PRESERVED_OLD_LIBCRYPT} -eq 1 ]] ; then
preserve_old_lib_notify /$(get_libdir)/libcrypt$(get_libname 1)
- cp "${T}"/crypt.h "${EROOT}"/usr/include/crypt.h || eerror "Error restoring crypt.h, please file a bug"
+
+ # Only copy if it exists; some people may have tiny embedded
+ # systems without headers: https://bugs.gentoo.org/802207#c16
+ if [[ -f "${T}"/crypt.h ]] ; then
+ cp "${T}"/crypt.h "${EROOT}"/usr/include/crypt.h || eerror "Error restoring crypt.h, please file a bug"
+ fi
+
elog "Please ignore a possible later error message about a file collision involving"
elog "/usr/include/crypt.h. We need to preserve this file for the moment to keep"
elog "the upgrade working, but it also needs to be overwritten when"