summaryrefslogtreecommitdiff
path: root/sys-libs/compiler-rt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-01 09:15:09 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-01 09:15:09 +0100
commita9b37934d0877c4249ea35c9e9c5b8cf3b836c9e (patch)
treeff0becf8e678416d9170f38891942c5df6c2557c /sys-libs/compiler-rt
parent0c764edfecb7e9e124d4669acd98bed09e23b6c0 (diff)
gentoo auto-resync : 01:08:2022 - 09:15:08
Diffstat (limited to 'sys-libs/compiler-rt')
-rw-r--r--sys-libs/compiler-rt/Manifest2
-rw-r--r--sys-libs/compiler-rt/compiler-rt-15.0.0.9999.ebuild15
2 files changed, 6 insertions, 11 deletions
diff --git a/sys-libs/compiler-rt/Manifest b/sys-libs/compiler-rt/Manifest
index c80a2f98d5e0..a963d60f1a0c 100644
--- a/sys-libs/compiler-rt/Manifest
+++ b/sys-libs/compiler-rt/Manifest
@@ -9,5 +9,5 @@ DIST llvmorg-14.0.4.tar.gz 158088617 BLAKE2B 7fb894548dce72593a8639b4d0220d24995
EBUILD compiler-rt-13.0.1.ebuild 3868 BLAKE2B b2b643b850023513b69076bc791b22b74aa54445250cba334a2d3dfdc26a1ea11d30d1ce9df6cb2d1c813b66eaa59a130821470b3a3076237f9ef93d2919a124 SHA512 334a2609ae6882dbbb9caca5bb3bc7ba0a668f9a8f337570d54bde926d7ebfaa87fe4e53dddc73ea602b2d52e7537b9490f8936736480f1ddac6c9caf7b6832d
EBUILD compiler-rt-14.0.4.ebuild 4017 BLAKE2B 9bb27fe3965eb71a40c3a9060e878e6cbefb5f3395b691a70ad6fc9ceeb352ae0d8275ce7165250c9857b8865367c9062c99dcef771e852830a171c0b0331d05 SHA512 3af70c7d10b15c324870b10368f66938402dd020ca9dfbe2aa82469442a76feeac9a09606e92a984fda7139a0779091ec0b96170a63abe95c014d90780788f8c
EBUILD compiler-rt-14.0.6.ebuild 4019 BLAKE2B f97793688c6e2dd3f2874217813ee9759bb896e192e146a2bc17e97daa0d9f8d8708938c68ab1270ef9dc49eb52bb7c29b4edd94382993e8de0a73f006238d23 SHA512 73a150cb917587e1e9a0adc499ae6cb1d473e455400b1b19777b30dea72846f01114bc52018dda7ff7090ea43b365793ad5a3515e4601dbd9ba4226c62322c77
-EBUILD compiler-rt-15.0.0.9999.ebuild 3958 BLAKE2B 8ce1194a4434fbfefe9edca0ed102a920afa85bc56d2cb0ed89ea7e525f11bd559a963de68504be03cad930b2611a2424b5511f1c92f924d684ea6a98d2851f6 SHA512 90bc2a25edc6d8aad2b21172651d2d220109ecc18166820e9bcfec68dc2a8541bc249a017d855d466cd148ee3f6f970191ed92f714ed68670e763bdfd7c06e27
+EBUILD compiler-rt-15.0.0.9999.ebuild 3725 BLAKE2B e599809889557255e7f9f5017ef685d85e3894477db00681f35ef285af9f97043160b08dc99f4f972519109366ebfd1fed34bfe8b452d3ca96a12d57aaf5e948 SHA512 881f8d4a464e19425a265cdb18d99ce85357d4aa206f3e9cfdf26536a05537146e1232199ae35da7f9f95382a175ca89fe48a59351ca3706a82f537159284d29
MISC metadata.xml 416 BLAKE2B 79a58249c94b605ba57f346c4e05b43853cf6cfb8bb65a4f4e3c44039cccfdb83dd31bfaaaf398bcbdc393efabdfc7ed186fe775976c46227e74decf2c8f4fb2 SHA512 ce30c79a575e5933effb1fec36f9a4ef02d9f97f312feb39c55a88cbda9a1bae1d7af2ec4ad5f66212cbb2cdbfb26f1a436689f16f410153c9d65eb010264c48
diff --git a/sys-libs/compiler-rt/compiler-rt-15.0.0.9999.ebuild b/sys-libs/compiler-rt/compiler-rt-15.0.0.9999.ebuild
index 8af221eaa8ad..8ef4aebf481d 100644
--- a/sys-libs/compiler-rt/compiler-rt-15.0.0.9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-15.0.0.9999.ebuild
@@ -32,7 +32,7 @@ BDEPEND="
)
"
-LLVM_COMPONENTS=( compiler-rt cmake llvm/cmake )
+LLVM_COMPONENTS=( runtimes compiler-rt cmake llvm/cmake )
LLVM_PATCHSET=9999-1
llvm.org_set_globals
@@ -70,7 +70,6 @@ src_configure() {
# pre-set since we need to pass it to cmake
BUILD_DIR=${WORKDIR}/${P}_build
- local nolib_flags=( -nodefaultlibs -nostartfiles -lc )
if use clang; then
# Only do this conditionally to allow overriding with
# e.g. CC=clang-13 in case of breakage
@@ -79,18 +78,14 @@ src_configure() {
local -x CXX=${CHOST}-clang++
fi
strip-unsupported-flags
- # ensure we can use clang before installing compiler-rt
- local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
- elif ! test_compiler; then
- if test_compiler "${nolib_flags[@]}"; then
- local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
- ewarn "${CC} seems to lack runtime, trying with ${nolib_flags[*]}"
- fi
fi
local mycmakeargs=(
- -DCOMPILER_RT_INSTALL_PATH="${EPREFIX}/usr/lib/clang/${SLOT}"
+ -DLLVM_ENABLE_RUNTIMES=compiler-rt
+ # this only adds unnecessary req on llvm-lit directory
+ -DLLVM_INCLUDE_TESTS=OFF
+ -DCOMPILER_RT_INSTALL_PATH="${EPREFIX}/usr/lib/clang/${SLOT}"
-DCOMPILER_RT_INCLUDE_TESTS=$(usex test)
-DCOMPILER_RT_BUILD_LIBFUZZER=OFF
-DCOMPILER_RT_BUILD_MEMPROF=OFF