summaryrefslogtreecommitdiff
path: root/sys-libs/compiler-rt/compiler-rt-9.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /sys-libs/compiler-rt/compiler-rt-9.0.1.ebuild
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'sys-libs/compiler-rt/compiler-rt-9.0.1.ebuild')
-rw-r--r--sys-libs/compiler-rt/compiler-rt-9.0.1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-9.0.1.ebuild b/sys-libs/compiler-rt/compiler-rt-9.0.1.ebuild
index f93feb036d6c..f5ce47c037e8 100644
--- a/sys-libs/compiler-rt/compiler-rt-9.0.1.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-9.0.1.ebuild
@@ -14,7 +14,7 @@ llvm.org_set_globals
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="$(ver_cut 1-3)"
-KEYWORDS="amd64 ~arm ~arm64 ppc64 x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+KEYWORDS="amd64 arm ~arm64 ppc64 x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="+clang test"
RESTRICT="!test? ( test ) !clang? ( test )"
@@ -25,7 +25,7 @@ DEPEND="
BDEPEND="
clang? ( sys-devel/clang )
test? (
- $(python_gen_any_dep "dev-python/lit[\${PYTHON_USEDEP}]")
+ $(python_gen_any_dep ">=dev-python/lit-9.0.1[\${PYTHON_USEDEP}]")
=sys-devel/clang-${PV%_*}*:${CLANG_SLOT} )
${PYTHON_DEPS}"
@@ -62,9 +62,9 @@ src_configure() {
if use clang; then
local -x CC=${CHOST}-clang
local -x CXX=${CHOST}-clang++
+ strip-unsupported-flags
# ensure we can use clang before installing compiler-rt
local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
- strip-unsupported-flags
elif ! test_compiler; then
if test_compiler "${nolib_flags[@]}"; then
local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"