summaryrefslogtreecommitdiff
path: root/sys-kernel
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-22 11:40:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-22 11:40:06 +0100
commit7a86906b67693cc65671d3e1476835d3a7e13092 (patch)
tree9de1b9e2cf77833183d4e5ffab2e94d0403ef725 /sys-kernel
parentd56d144655e3785864da43c9acb6c228ef9360ae (diff)
gentoo resync : 22.06.2019
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/genkernel-next/genkernel-next-70.ebuild51
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-4.14.127.ebuild28
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-4.14.128.ebuild28
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-4.19.52.ebuild28
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-4.19.53.ebuild28
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-4.4.182.ebuild28
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-4.9.182.ebuild28
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-5.1.11.ebuild28
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-5.1.12.ebuild28
-rw-r--r--sys-kernel/git-sources/git-sources-5.2_rc5.ebuild40
-rw-r--r--sys-kernel/vanilla-sources/vanilla-sources-3.16.69.ebuild16
-rw-r--r--sys-kernel/vanilla-sources/vanilla-sources-4.14.128.ebuild16
-rw-r--r--sys-kernel/vanilla-sources/vanilla-sources-4.19.53.ebuild16
-rw-r--r--sys-kernel/vanilla-sources/vanilla-sources-4.4.182.ebuild16
-rw-r--r--sys-kernel/vanilla-sources/vanilla-sources-4.9.182.ebuild16
-rw-r--r--sys-kernel/vanilla-sources/vanilla-sources-5.1.12.ebuild16
16 files changed, 411 insertions, 0 deletions
diff --git a/sys-kernel/genkernel-next/genkernel-next-70.ebuild b/sys-kernel/genkernel-next/genkernel-next-70.ebuild
new file mode 100644
index 000000000000..80e938e9c826
--- /dev/null
+++ b/sys-kernel/genkernel-next/genkernel-next-70.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+SRC_URI="https://github.com/Sabayon/genkernel-next/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+inherit bash-completion-r1
+
+DESCRIPTION="Gentoo automatic kernel building scripts, reloaded"
+HOMEPAGE="https://github.com/Sabayon/genkernel-next/"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="cryptsetup dmraid gpg iscsi mdadm plymouth selinux"
+DOCS=( AUTHORS )
+
+DEPEND="app-text/asciidoc
+ sys-fs/e2fsprogs
+ !sys-fs/eudev[-kmod,modutils]
+ selinux? ( sys-libs/libselinux )"
+RDEPEND="${DEPEND}
+ !sys-kernel/genkernel
+ cryptsetup? ( sys-fs/cryptsetup )
+ dmraid? ( >=sys-fs/dmraid-1.0.0_rc16 )
+ gpg? ( app-crypt/gnupg )
+ iscsi? ( sys-block/open-iscsi )
+ mdadm? ( sys-fs/mdadm )
+ plymouth? ( sys-boot/plymouth )
+ app-portage/portage-utils
+ app-arch/cpio
+ >=app-misc/pax-utils-0.6
+ !<sys-apps/openrc-0.9.9
+ sys-apps/util-linux
+ sys-block/thin-provisioning-tools
+ sys-fs/lvm2"
+
+src_prepare() {
+ default
+ sed -i "/^GK_V=/ s:GK_V=.*:GK_V=${PV}:g" "${S}/genkernel" || \
+ die "Could not setup release"
+}
+
+src_install() {
+ default
+
+ doman "${S}"/genkernel.8
+
+ newbashcomp "${S}"/genkernel.bash genkernel
+}
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-4.14.127.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-4.14.127.ebuild
new file mode 100644
index 000000000000..e45748664e38
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-4.14.127.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="135"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh sparc x86"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-4.14.128.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-4.14.128.ebuild
new file mode 100644
index 000000000000..d20876a11e4f
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-4.14.128.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="136"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-4.19.52.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-4.19.52.ebuild
new file mode 100644
index 000000000000..3db948433f22
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-4.19.52.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="53"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh sparc x86"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-4.19.53.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-4.19.53.ebuild
new file mode 100644
index 000000000000..acfee55849d8
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-4.19.53.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="54"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-4.4.182.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-4.4.182.ebuild
new file mode 100644
index 000000000000..7f45847916d6
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-4.4.182.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="183"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh sparc x86"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-4.9.182.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-4.9.182.ebuild
new file mode 100644
index 000000000000..f2549815e24f
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-4.9.182.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="187"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh sparc x86"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-5.1.11.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-5.1.11.ebuild
new file mode 100644
index 000000000000..15f3a0ffff88
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-5.1.11.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="12"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-5.1.12.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-5.1.12.ebuild
new file mode 100644
index 000000000000..e0df69ac4fbf
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-5.1.12.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="13"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}
diff --git a/sys-kernel/git-sources/git-sources-5.2_rc5.ebuild b/sys-kernel/git-sources/git-sources-5.2_rc5.ebuild
new file mode 100644
index 000000000000..8509b233b0a2
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-5.2_rc5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.1"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}
diff --git a/sys-kernel/vanilla-sources/vanilla-sources-3.16.69.ebuild b/sys-kernel/vanilla-sources/vanilla-sources-3.16.69.ebuild
new file mode 100644
index 000000000000..6f2f5701c4ee
--- /dev/null
+++ b/sys-kernel/vanilla-sources/vanilla-sources-3.16.69.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_SECURITY_UNSUPPORTED="1"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="Full sources for the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
diff --git a/sys-kernel/vanilla-sources/vanilla-sources-4.14.128.ebuild b/sys-kernel/vanilla-sources/vanilla-sources-4.14.128.ebuild
new file mode 100644
index 000000000000..6f2f5701c4ee
--- /dev/null
+++ b/sys-kernel/vanilla-sources/vanilla-sources-4.14.128.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_SECURITY_UNSUPPORTED="1"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="Full sources for the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
diff --git a/sys-kernel/vanilla-sources/vanilla-sources-4.19.53.ebuild b/sys-kernel/vanilla-sources/vanilla-sources-4.19.53.ebuild
new file mode 100644
index 000000000000..6f2f5701c4ee
--- /dev/null
+++ b/sys-kernel/vanilla-sources/vanilla-sources-4.19.53.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_SECURITY_UNSUPPORTED="1"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="Full sources for the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
diff --git a/sys-kernel/vanilla-sources/vanilla-sources-4.4.182.ebuild b/sys-kernel/vanilla-sources/vanilla-sources-4.4.182.ebuild
new file mode 100644
index 000000000000..6f2f5701c4ee
--- /dev/null
+++ b/sys-kernel/vanilla-sources/vanilla-sources-4.4.182.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_SECURITY_UNSUPPORTED="1"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="Full sources for the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
diff --git a/sys-kernel/vanilla-sources/vanilla-sources-4.9.182.ebuild b/sys-kernel/vanilla-sources/vanilla-sources-4.9.182.ebuild
new file mode 100644
index 000000000000..6f2f5701c4ee
--- /dev/null
+++ b/sys-kernel/vanilla-sources/vanilla-sources-4.9.182.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_SECURITY_UNSUPPORTED="1"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="Full sources for the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
diff --git a/sys-kernel/vanilla-sources/vanilla-sources-5.1.12.ebuild b/sys-kernel/vanilla-sources/vanilla-sources-5.1.12.ebuild
new file mode 100644
index 000000000000..6f2f5701c4ee
--- /dev/null
+++ b/sys-kernel/vanilla-sources/vanilla-sources-5.1.12.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_SECURITY_UNSUPPORTED="1"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="Full sources for the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"