summaryrefslogtreecommitdiff
path: root/sys-kernel/spl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-15 16:58:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-15 16:58:00 +0000
commit434d713861b70f6c6563d6ee50a8e64f14c970d9 (patch)
treeb72c523c72e764420f835ba9d63d43ffef687dcf /sys-kernel/spl
parentf78108598211053d41752a83e0345441bb9014ae (diff)
gentoo resync : 15.02.2018
Diffstat (limited to 'sys-kernel/spl')
-rw-r--r--sys-kernel/spl/Manifest1
-rw-r--r--sys-kernel/spl/spl-0.7.9999.ebuild113
2 files changed, 114 insertions, 0 deletions
diff --git a/sys-kernel/spl/Manifest b/sys-kernel/spl/Manifest
index 6c41aa6ce5af..71bf10e85d76 100644
--- a/sys-kernel/spl/Manifest
+++ b/sys-kernel/spl/Manifest
@@ -7,5 +7,6 @@ EBUILD spl-0.6.5.11.ebuild 2708 BLAKE2B 97b92f5e3ee8635caea44103446ccebf89457744
EBUILD spl-0.6.5.4-r1.ebuild 2924 BLAKE2B 496213b2c56731291103b98595daf77ae5748f2514022eca2e8c39e172f485019c1fabbad80d5e4d3029d73a9cd62e4618cdb194ad3172a44bdad060da27f57b SHA512 4092f4be37805660a15982bdedc05d1650789e2711ba550cbbbe7171929ce58e7157221991210f8f5f496bbe897af6d8aef5435058a31984a692c2324d8ed494
EBUILD spl-0.7.5.ebuild 2708 BLAKE2B 24502e8b7bc0d3b4f180cfa0163121dc0fcb4b4524cf062a3e75e95e501b1d1d1c4d7e9c416eff2dd5a114eae77bc99358de74bf77760ef7d7c1b63de8066565 SHA512 4d9199c47278c8b432017432ea7f916fb6ae155b96972e7b53f7b633ef0617cca3a09235e635674711a9e733575d8e3aa4ad9de53bf910d55036865666bb3509
EBUILD spl-0.7.6.ebuild 2687 BLAKE2B a2671237360f4169cb3de8d419604b45e486fb6f54fbd4cb645a6a32f8fe109a86d81504bfe69c93213b44677c0bf99fafa4641bbc948c7ee2998f56c8cbafc1 SHA512 7c50bcd5e4751f3f0cc2db4ba11029a47b84a696aab725d502dfaeb3da4a824cdfc0c4213af0058ae14bc27be54487e3aab6d5a0360808648b795d520c8dc54e
+EBUILD spl-0.7.9999.ebuild 2778 BLAKE2B 07296e3768b48b6c4047180f74e3374d402ec87638c448ac39023785db3ce819fe45d7c134fc79fad507f724b24d381b216f89ddbc9d44528a07fe6392e06a71 SHA512 29cd683cd14f8a61b8a9772d05e5d56702529e1f57602a37922680561cbe09e00d3167961d757133ce5e24b0145e930cbabb82c94070f629e2f8ebf0a6fa72a1
EBUILD spl-9999.ebuild 2744 BLAKE2B bf65299df864ef7a983532e23c8f5764fd30701ad2c24face5c4cd1cf41fd24abe2dc7e57001d1b1a7d8353a21a85737f305d00910bac285723294faa4b8728e SHA512 ccfae24c381d939ce22dd3a745f8ee1933803cb49761f73eb58c54b0a8e915a40155efc088c95549461538af7cec4d2460bff904a4a5c14276d0c373cd1d8729
MISC metadata.xml 436 BLAKE2B df6b2b25107b10b62618306f09e48f4337315792390c58392f73b270466f4927209dba0d8d1f1d8b8f65f345bce077a7b738f240f077a0eb26c23353673d412f SHA512 1b867378bde3ac034a7fbdc84e47b77b570ecf7a7688b0dc47950de7ea6601284c8101600928ddb7725f7a09ecc73eb01bdf646b0ecca250029e3063a4427ca8
diff --git a/sys-kernel/spl/spl-0.7.9999.ebuild b/sys-kernel/spl/spl-0.7.9999.ebuild
new file mode 100644
index 000000000000..a8d89680db28
--- /dev/null
+++ b/sys-kernel/spl/spl-0.7.9999.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+if [[ ${PV} == *"9999" ]] ; then
+ AUTOTOOLS_AUTORECONF="1"
+ EGIT_REPO_URI="https://github.com/zfsonlinux/${PN}.git"
+ EGIT_BRANCH="spl-0.7-release"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/zfsonlinux/zfs/releases/download/zfs-${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc ~ppc64"
+fi
+
+inherit flag-o-matic linux-info linux-mod autotools-utils
+
+DESCRIPTION="The Solaris Porting Layer provides many of the Solaris kernel APIs"
+HOMEPAGE="http://zfsonlinux.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="custom-cflags debug"
+RESTRICT="debug? ( strip ) test"
+
+COMMON_DEPEND="
+ dev-lang/perl
+ virtual/awk"
+
+DEPEND="${COMMON_DEPEND}"
+
+RDEPEND="${COMMON_DEPEND}
+ !sys-devel/spl"
+
+AT_M4DIR="config"
+AUTOTOOLS_IN_SOURCE_BUILD="1"
+DOCS=( AUTHORS DISCLAIMER README.markdown )
+
+pkg_setup() {
+ linux-info_pkg_setup
+ CONFIG_CHECK="
+ !DEBUG_LOCK_ALLOC
+ !CONFIG_REISER4_FS
+ !GRKERNSEC_RANDSTRUCT
+ KALLSYMS
+ MODULES
+ !PAX_KERNEXEC_PLUGIN_METHOD_OR
+ ZLIB_DEFLATE
+ ZLIB_INFLATE
+ "
+
+ use debug && CONFIG_CHECK="${CONFIG_CHECK}
+ FRAME_POINTER
+ DEBUG_INFO
+ !DEBUG_INFO_REDUCED
+ "
+
+ kernel_is ge 2 6 32 || die "Linux 2.6.32 or newer required"
+
+ [ ${PV} != *"9999" ] && \
+ { kernel_is le 4 15 || die "Linux 4.15 is the latest supported version."; }
+
+ check_extra_config
+}
+
+src_prepare() {
+ # Workaround for hard coded path
+ sed -i "s|/sbin/lsmod|/bin/lsmod|" "${S}/scripts/check.sh" || \
+ die "Cannot patch check.sh"
+
+ # splat is unnecessary unless we are debugging
+ use debug || { sed -e 's/^subdir-m += splat$//' -i "${S}/module/Makefile.in" || die ; }
+
+ # Set module revision number
+ [ ${PV} != *"9999" ] && \
+ { sed -i "s/\(Release:\)\(.*\)1/\1\2${PR}-gentoo/" "${S}/META" || die "Could not set Gentoo release"; }
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ use custom-cflags || strip-flags
+ filter-ldflags -Wl,*
+
+ set_arch_to_kernel
+ local myeconfargs=(
+ --bindir="${EPREFIX}/bin"
+ --sbindir="${EPREFIX}/sbin"
+ --with-config=all
+ --with-linux="${KV_DIR}"
+ --with-linux-obj="${KV_OUT_DIR}"
+ $(use_enable debug)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install INSTALL_MOD_PATH="${INSTALL_MOD_PATH:-$EROOT}"
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ # Remove old modules
+ if [ -d "${EROOT}lib/modules/${KV_FULL}/addon/spl" ]
+ then
+ ewarn "${PN} now installs modules in ${EROOT}lib/modules/${KV_FULL}/extra/spl"
+ ewarn "Old modules were detected in ${EROOT}lib/modules/${KV_FULL}/addon/spl"
+ ewarn "Automatically removing old modules to avoid problems."
+ rm -r "${EROOT}lib/modules/${KV_FULL}/addon/spl" || die "Cannot remove modules"
+ rmdir --ignore-fail-on-non-empty "${EROOT}lib/modules/${KV_FULL}/addon"
+ fi
+}