summaryrefslogtreecommitdiff
path: root/sys-kernel/raspberrypi-sources/raspberrypi-sources-5.10.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /sys-kernel/raspberrypi-sources/raspberrypi-sources-5.10.9999.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'sys-kernel/raspberrypi-sources/raspberrypi-sources-5.10.9999.ebuild')
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-5.10.9999.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-5.10.9999.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-5.10.9999.ebuild
new file mode 100644
index 000000000000..d6ff24d0a8fa
--- /dev/null
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-5.10.9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ETYPE=sources
+K_DEFCONFIG="bcmrpi_defconfig"
+K_SECURITY_UNSUPPORTED=1
+EXTRAVERSION="-${PN}/-*"
+inherit kernel-2
+detect_version
+detect_arch
+
+inherit git-r3
+EGIT_REPO_URI="https://github.com/raspberrypi/linux.git -> raspberrypi-linux.git"
+EGIT_BRANCH="rpi-$(ver_cut 1-2).y"
+EGIT_CHECKOUT_DIR="${WORKDIR}/linux-${PV}-raspberrypi"
+EGIT_CLONE_TYPE="shallow"
+
+DESCRIPTION="Raspberry Pi kernel sources"
+HOMEPAGE="https://github.com/raspberrypi/linux"
+
+src_unpack() {
+ git-r3_src_unpack
+ unpack_set_extraversion
+}