summaryrefslogtreecommitdiff
path: root/sys-kernel/raspberrypi-image/raspberrypi-image-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /sys-kernel/raspberrypi-image/raspberrypi-image-9999.ebuild
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'sys-kernel/raspberrypi-image/raspberrypi-image-9999.ebuild')
-rw-r--r--sys-kernel/raspberrypi-image/raspberrypi-image-9999.ebuild58
1 files changed, 17 insertions, 41 deletions
diff --git a/sys-kernel/raspberrypi-image/raspberrypi-image-9999.ebuild b/sys-kernel/raspberrypi-image/raspberrypi-image-9999.ebuild
index 0e6d2da6e687..6bd6d37a4aaf 100644
--- a/sys-kernel/raspberrypi-image/raspberrypi-image-9999.ebuild
+++ b/sys-kernel/raspberrypi-image/raspberrypi-image-9999.ebuild
@@ -1,57 +1,33 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit git-r3 readme.gentoo-r1
+inherit mount-boot
-DESCRIPTION="Raspberry PI boot loader and firmware"
+DESCRIPTION="Raspberry Pi (all versions) kernel and modules"
HOMEPAGE="https://github.com/raspberrypi/firmware"
-SRC_URI=""
-
LICENSE="GPL-2 raspberrypi-videocore-bin"
SLOT="0"
-KEYWORDS=""
-IUSE=""
-
-EGIT_REPO_URI="https://github.com/raspberrypi/firmware"
-DOC_CONTENTS="Please configure your ram setup by editing /boot/config.txt"
-
RESTRICT="binchecks strip"
-pkg_preinst() {
- if [ -z "${REPLACING_VERSIONS}" ] ; then
- local msg=""
- if [ -e "${D}"/boot/cmdline.txt -a -e "${ROOT}"/boot/cmdline.txt ] ; then
- msg+="/boot/cmdline.txt "
- fi
- if [ -e "${D}"/boot/config.txt -a -e "${ROOT}"/boot/config.txt ] ; then
- msg+="/boot/config.txt "
- fi
- if [ -n "${msg}" ] ; then
- msg="This package installs following files: ${msg}."
- msg="${msg} Please remove(backup) your copies during install"
- msg="${msg} and merge settings afterwards."
- msg="${msg} Further updates will be CONFIG_PROTECTed."
- die "${msg}"
- fi
- fi
+RDEPEND="sys-boot/raspberrypi-firmware"
- if ! grep "${ROOT}boot" /proc/mounts >/dev/null 2>&1; then
- ewarn "${ROOT}boot is not mounted, the files might not be installed at the right place"
- fi
-}
-
-src_configure() { :; }
-
-src_compile() { :; }
+if [[ "${PV}" == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/raspberrypi/firmware"
+ EGIT_CLONE_TYPE="shallow"
+else
+ [[ "$(ver_cut 4)" == 'p' ]] || die "Unsupported version format, tweak the ebuild."
+ MY_PV="1.$(ver_cut 5)"
+ SRC_URI="https://github.com/raspberrypi/firmware/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/firmware-${MY_PV}"
+ KEYWORDS="-* ~arm"
+fi
src_install() {
insinto /lib/modules
doins -r modules/*
insinto /boot
- newins boot/kernel.img kernel.img
- newins boot/kernel7.img kernel7.img
-
- readme.gentoo_create_doc
+ doins boot/*.img
}