summaryrefslogtreecommitdiff
path: root/sys-kernel/linux-headers/linux-headers-6.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-27 07:01:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-27 07:01:35 +0000
commite5558bb40ba46b03d0c8e82ae60dce9a32933989 (patch)
tree85455876dea191e90114ff262f0d971533de9cd0 /sys-kernel/linux-headers/linux-headers-6.8.ebuild
parent0b8b325c6d134a9f66de2ba751280e6480e609af (diff)
gentoo auto-resync : 27:03:2024 - 07:01:35
Diffstat (limited to 'sys-kernel/linux-headers/linux-headers-6.8.ebuild')
-rw-r--r--sys-kernel/linux-headers/linux-headers-6.8.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/sys-kernel/linux-headers/linux-headers-6.8.ebuild b/sys-kernel/linux-headers/linux-headers-6.8.ebuild
deleted file mode 100644
index 09d006337834..000000000000
--- a/sys-kernel/linux-headers/linux-headers-6.8.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-ETYPE="headers"
-H_SUPPORTEDARCH="alpha amd64 arc arm arm64 csky hexagon hppa loong m68k microblaze mips nios2 openrisc ppc ppc64 riscv s390 sh sparc x86 xtensa"
-inherit kernel-2
-detect_version
-
-PATCH_PV=${PV} # to ease testing new versions against not existing patches
-PATCH_VER="1"
-PATCH_DEV="sam"
-SRC_URI="
- ${KERNEL_URI}
- ${PATCH_VER:+https://dev.gentoo.org/~${PATCH_DEV}/distfiles/sys-kernel/linux-headers/gentoo-headers-${PATCH_PV}-${PATCH_VER}.tar.xz}
-"
-S="${WORKDIR}/linux-${PV}"
-
-# Unkeyworded for testing
-#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa -ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-
-BDEPEND="
- app-arch/xz-utils
- dev-lang/perl
-"
-
-[[ -n ${PATCH_VER} ]] && PATCHES=( "${WORKDIR}"/${PATCH_PV} )
-
-src_unpack() {
- # Avoid kernel-2_src_unpack
- default
-}
-
-src_prepare() {
- # TODO: May need forward porting to newer versions
- use elibc_musl && PATCHES+=(
- "${FILESDIR}"/${PN}-5.15-remove-inclusion-sysinfo.h.patch
- )
-
- # Avoid kernel-2_src_prepare
- default
-}
-
-src_install() {
- kernel-2_src_install
-
- find "${ED}" \( -name '.install' -o -name '*.cmd' \) -delete || die
- # Delete empty directories
- find "${ED}" -empty -type d -delete || die
-}