summaryrefslogtreecommitdiff
path: root/sys-kernel/linux-headers/linux-headers-6.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-28 07:37:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-28 07:37:55 +0000
commitd46d1d3a5897cade51811b3848c7bf27969da625 (patch)
tree0dabb04db53e3fe66abe43df0a3cdff5d3b664db /sys-kernel/linux-headers/linux-headers-6.4.ebuild
parente67d5b4ba05349b3bf4229d0cf7d069809c4420e (diff)
gentoo auto-resync : 28:12:2023 - 07:37:55
Diffstat (limited to 'sys-kernel/linux-headers/linux-headers-6.4.ebuild')
-rw-r--r--sys-kernel/linux-headers/linux-headers-6.4.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/sys-kernel/linux-headers/linux-headers-6.4.ebuild b/sys-kernel/linux-headers/linux-headers-6.4.ebuild
deleted file mode 100644
index cc9b5489c81e..000000000000
--- a/sys-kernel/linux-headers/linux-headers-6.4.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-ETYPE="headers"
-H_SUPPORTEDARCH="alpha amd64 arc arm arm64 csky hexagon hppa ia64 loong m68k microblaze mips nios2 openrisc ppc ppc64 riscv s390 sh sparc x86 xtensa"
-inherit kernel-2
-detect_version
-
-PATCH_PV=${PV} # to ease testing new versions against not existing patches
-PATCH_VER="1"
-PATCH_DEV="sam"
-SRC_URI="
- ${KERNEL_URI}
- ${PATCH_VER:+https://dev.gentoo.org/~${PATCH_DEV}/distfiles/sys-kernel/linux-headers/gentoo-headers-${PATCH_PV}-${PATCH_VER}.tar.xz}
-"
-S="${WORKDIR}/linux-${PV}"
-
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-
-BDEPEND="
- app-arch/xz-utils
- dev-lang/perl
-"
-
-[[ -n ${PATCH_VER} ]] && PATCHES=( "${WORKDIR}"/${PATCH_PV} )
-
-src_unpack() {
- # Avoid kernel-2_src_unpack
- default
-}
-
-src_prepare() {
- # TODO: May need forward porting to newer versions
- use elibc_musl && PATCHES+=(
- "${FILESDIR}"/${PN}-5.15-remove-inclusion-sysinfo.h.patch
- )
-
- # Avoid kernel-2_src_prepare
- default
-}
-
-src_install() {
- kernel-2_src_install
-
- find "${ED}" \( -name '.install' -o -name '*.cmd' \) -delete || die
- # Delete empty directories
- find "${ED}" -empty -type d -delete || die
-}