summaryrefslogtreecommitdiff
path: root/sys-kernel/linux-headers/linux-headers-5.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /sys-kernel/linux-headers/linux-headers-5.4-r1.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'sys-kernel/linux-headers/linux-headers-5.4-r1.ebuild')
-rw-r--r--sys-kernel/linux-headers/linux-headers-5.4-r1.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/sys-kernel/linux-headers/linux-headers-5.4-r1.ebuild b/sys-kernel/linux-headers/linux-headers-5.4-r1.ebuild
index 5abde3861641..827a8767d0fd 100644
--- a/sys-kernel/linux-headers/linux-headers-5.4-r1.ebuild
+++ b/sys-kernel/linux-headers/linux-headers-5.4-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -15,7 +15,7 @@ SRC_URI="${KERNEL_URI}
${PATCH_VER:+https://dev.gentoo.org/~slyfox/distfiles/gentoo-headers-${PATCH_PV}-${PATCH_VER}.tar.xz}
"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
DEPEND="app-arch/xz-utils
dev-lang/perl"
@@ -33,6 +33,10 @@ src_prepare() {
default
}
+src_test() {
+ emake ARCH=$(tc-arch-kernel) headers_check
+}
+
src_install() {
kernel-2_src_install
@@ -40,7 +44,3 @@ src_install() {
find "${ED}" '(' -name '.install' -o -name '*.cmd' ')' -delete
find "${ED}" -depth -type d -delete 2>/dev/null
}
-
-src_test() {
- emake ARCH=$(tc-arch-kernel) headers_check
-}