summaryrefslogtreecommitdiff
path: root/sys-kernel/linux-headers/linux-headers-3.18.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /sys-kernel/linux-headers/linux-headers-3.18.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'sys-kernel/linux-headers/linux-headers-3.18.ebuild')
-rw-r--r--sys-kernel/linux-headers/linux-headers-3.18.ebuild27
1 files changed, 12 insertions, 15 deletions
diff --git a/sys-kernel/linux-headers/linux-headers-3.18.ebuild b/sys-kernel/linux-headers/linux-headers-3.18.ebuild
index ba6ba023e84d..a9b5d7f61969 100644
--- a/sys-kernel/linux-headers/linux-headers-3.18.ebuild
+++ b/sys-kernel/linux-headers/linux-headers-3.18.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,7 +12,7 @@ PATCH_VER="1"
SRC_URI="mirror://gentoo/gentoo-headers-base-${PV}.tar.xz
${PATCH_VER:+mirror://gentoo/gentoo-headers-${PV}-${PATCH_VER}.tar.xz}"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
DEPEND="app-arch/xz-utils
dev-lang/perl"
@@ -30,6 +30,16 @@ src_prepare() {
[[ -n ${PATCH_VER} ]] && eapply "${WORKDIR}/${PV}"/*.patch
}
+src_test() {
+ einfo "Possible unescaped attribute/type usage"
+ egrep -r \
+ -e '(^|[[:space:](])(asm|volatile|inline)[[:space:](]' \
+ -e '\<([us](8|16|32|64))\>' \
+ .
+
+ emake ARCH=$(tc-arch-kernel) headers_check
+}
+
src_install() {
kernel-2_src_install
@@ -40,16 +50,3 @@ src_install() {
# provided by libdrm (for now?)
rm -rf "${ED}"/$(kernel_header_destdir)/drm
}
-
-src_test() {
- einfo "Possible unescaped attribute/type usage"
- egrep -r \
- -e '(^|[[:space:](])(asm|volatile|inline)[[:space:](]' \
- -e '\<([us](8|16|32|64))\>' \
- .
-
- einfo "Missing linux/types.h include"
- egrep -l -r -e '__[us](8|16|32|64)' "${ED}" | xargs grep -L linux/types.h
-
- emake ARCH=$(tc-arch-kernel) headers_check
-}