summaryrefslogtreecommitdiff
path: root/sys-kernel/linux-firmware
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-14 04:04:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-14 04:04:03 +0100
commit2916cf6049cf9d3092021e247d56c580df6029a7 (patch)
treec796a6fc8b6fd0e4fd5ac06b009000b438fed7d9 /sys-kernel/linux-firmware
parent7b5306e0d287565138e8b051e32f57e6af6ae0ed (diff)
gentoo auto-resync : 14:10:2024 - 04:04:03
Diffstat (limited to 'sys-kernel/linux-firmware')
-rw-r--r--sys-kernel/linux-firmware/Manifest2
-rw-r--r--sys-kernel/linux-firmware/linux-firmware-99999999.ebuild15
2 files changed, 13 insertions, 4 deletions
diff --git a/sys-kernel/linux-firmware/Manifest b/sys-kernel/linux-firmware/Manifest
index f84d9e16a29c..1f4bf5a22856 100644
--- a/sys-kernel/linux-firmware/Manifest
+++ b/sys-kernel/linux-firmware/Manifest
@@ -8,5 +8,5 @@ DIST linux-firmware-20240909.tar.xz 383099276 BLAKE2B 3769ca5501db43a6d1ca54ac11
EBUILD linux-firmware-20240709-r2.ebuild 11025 BLAKE2B 8362004307337300997032efa50bbcedf2380c7c1c66915773396b2c5567ccab067d596cf8cdd1c607bcce4e956cd3e1e7b55fbeaa4537bb63d40eac498df997 SHA512 271a506d8b039af9209df63145a4522dc245fbd554a3a95478bf8911e73b28287073c76e549368f3639ed85a65def43b1bd3666b49e645006dba09f57fb7bf36
EBUILD linux-firmware-20240811-r1.ebuild 11025 BLAKE2B 8362004307337300997032efa50bbcedf2380c7c1c66915773396b2c5567ccab067d596cf8cdd1c607bcce4e956cd3e1e7b55fbeaa4537bb63d40eac498df997 SHA512 271a506d8b039af9209df63145a4522dc245fbd554a3a95478bf8911e73b28287073c76e549368f3639ed85a65def43b1bd3666b49e645006dba09f57fb7bf36
EBUILD linux-firmware-20240909-r1.ebuild 11025 BLAKE2B 8362004307337300997032efa50bbcedf2380c7c1c66915773396b2c5567ccab067d596cf8cdd1c607bcce4e956cd3e1e7b55fbeaa4537bb63d40eac498df997 SHA512 271a506d8b039af9209df63145a4522dc245fbd554a3a95478bf8911e73b28287073c76e549368f3639ed85a65def43b1bd3666b49e645006dba09f57fb7bf36
-EBUILD linux-firmware-99999999.ebuild 11321 BLAKE2B 9e941ca1b6ff5bc683638a1ae514fbbce3cbfbd0540c07c988183d20d9baa79a450f85c02c7e2ab426cfd4eab9fa3b373a6cd5b6914e23a4724b211fdec320a8 SHA512 3e527ee380cf95df54b3e90d43d8a0666f091893d2d7c170abc8916f38c2d0481664fb48f20301776d9d878ef6f9777a6de81434f8861bd02564cd2828f7d3cf
+EBUILD linux-firmware-99999999.ebuild 11516 BLAKE2B 63bd0c84fe8e9a33e310175a419f2f09553d43819e3bf3dedd01e86ea71b5596f93d3f0764bf76861c50870cf967888e9a45943e88cc4232f099d6b683097149 SHA512 53f61a8213080e3cbde17244ca4dc20fa5ce9feece9a4f4967671443eb0ac09c3921a37a4ba66334aa0166438a7d01940abe41bbed358c5e60d2334071d6627b
MISC metadata.xml 1289 BLAKE2B 109336d30e5ec5fb5e679cff9b31e6f69c0b4f629e2aaf4d0d7b6c0db78c1ddcbbb0b283f724f2758207324b622c2af9dfe15874ab34b34876e3e4f58cb5ced6 SHA512 9b925b26bb58a39360ab5ff3cdd7d88bd489645e73f101209f0813a0b926b15dae34f28db05ff6419a0a62fab2ac84ae0546b5007ce17ad3611188bf7aeda3e5
diff --git a/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild b/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild
index d96b4b85e55b..a177433c8846 100644
--- a/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild
+++ b/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit dist-kernel-utils linux-info mount-boot savedconfig
+PYTHON_COMPAT=( python3_{10..13} )
+inherit dist-kernel-utils linux-info mount-boot python-any-r1 savedconfig
# In case this is a real snapshot, fill in commit below.
# For normal, tagged releases, leave blank
@@ -40,7 +41,8 @@ RESTRICT="binchecks strip test
BDEPEND="initramfs? ( app-alternatives/cpio )
compress-xz? ( app-arch/xz-utils )
compress-zstd? ( app-arch/zstd )
- deduplicate? ( app-misc/rdfind )"
+ deduplicate? ( app-misc/rdfind )
+ ${PYTHON_DEPS}"
#add anything else that collides to this
RDEPEND="!savedconfig? (
@@ -84,6 +86,9 @@ pkg_pretend() {
}
pkg_setup() {
+
+ python_setup
+
if use compress-xz || use compress-zstd ; then
local CONFIG_CHECK
@@ -120,6 +125,8 @@ src_prepare() {
|| die
chmod +x copy-firmware.sh || die
+ chmod +x dedup-firmware.sh || die
+ chmod +x check_whence.py || die
cp "${FILESDIR}/${PN}-make-amd-ucode-img.bash" "${T}/make-amd-ucode-img" || die
chmod +x "${T}/make-amd-ucode-img" || die
@@ -136,6 +143,8 @@ src_prepare() {
# whitelist of misc files
local misc_files=(
copy-firmware.sh
+ dedup-firmware.sh
+ check_whence.py
WHENCE
README
)
@@ -284,9 +293,9 @@ src_install() {
elif use compress-zstd; then
FW_OPTIONS+=( "--zstd" )
fi
- ! use deduplicate && FW_OPTIONS+=( "--ignore-duplicates" )
FW_OPTIONS+=( "${ED}/lib/firmware" )
./copy-firmware.sh "${FW_OPTIONS[@]}" || die
+ use deduplicate && ./dedup-firmware.sh "${ED}/lib/firmware" || die
pushd "${ED}/lib/firmware" &>/dev/null || die