summaryrefslogtreecommitdiff
path: root/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-26 11:42:28 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-26 11:42:28 +0000
commit89c6c06b8c42107dd231687a1012354e7d3039fc (patch)
treedad94f4da8a6694f3cb99f7048be2f9cf5f78f97 /sys-kernel/linux-firmware/linux-firmware-99999999.ebuild
parent796cae72cf9ed18ba01256ac1f83a686a2a76036 (diff)
gentoo resync : 26.11.2017
Diffstat (limited to 'sys-kernel/linux-firmware/linux-firmware-99999999.ebuild')
-rw-r--r--sys-kernel/linux-firmware/linux-firmware-99999999.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild b/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild
index b3a27592e5b2..1056574b8066 100644
--- a/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild
+++ b/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild
@@ -1,16 +1,17 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
inherit savedconfig
if [[ ${PV} == 99999999* ]]; then
- inherit git-2
+ inherit git-r3
SRC_URI=""
- EGIT_REPO_URI="git://git.kernel.org/pub/scm/linux/kernel/git/firmware/${PN}.git"
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/linux/kernel/git/firmware/${PN}.git"
KEYWORDS=""
else
- SRC_URI="mirror://gentoo/${P}.tar.xz"
+ GIT_COMMIT=""
+ SRC_URI="https://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git/snapshot/linux-firmware-${GIT_COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
fi
@@ -63,9 +64,11 @@ RDEPEND="!savedconfig? (
)"
#add anything else that collides to this
+QA_PREBUILT="lib/firmware/*"
+
src_unpack() {
if [[ ${PV} == 99999999* ]]; then
- git-2_src_unpack
+ git-r3_src_unpack
else
default
# rename directory from git snapshot tarball
@@ -74,6 +77,7 @@ src_unpack() {
}
src_prepare() {
+ default
echo "# Remove files that shall not be installed from this list." > ${PN}.conf
find * \( \! -type d -and \! -name ${PN}.conf \) >> ${PN}.conf