summaryrefslogtreecommitdiff
path: root/sys-kernel/linux-docs/linux-docs-5.15.53.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /sys-kernel/linux-docs/linux-docs-5.15.53.ebuild
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'sys-kernel/linux-docs/linux-docs-5.15.53.ebuild')
-rw-r--r--sys-kernel/linux-docs/linux-docs-5.15.53.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-kernel/linux-docs/linux-docs-5.15.53.ebuild b/sys-kernel/linux-docs/linux-docs-5.15.53.ebuild
new file mode 100644
index 000000000000..d3b98d3f984a
--- /dev/null
+++ b/sys-kernel/linux-docs/linux-docs-5.15.53.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9,10,11} )
+inherit linux-info python-any-r1 toolchain-funcs
+
+MY_PV="$(ver_cut 1-2)"
+MY_P=linux-${MY_PV}
+
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Developer documentation generated from the Linux kernel"
+HOMEPAGE="https://www.kernel.org/"
+SRC_URI="https://www.kernel.org/pub/linux/kernel/v5.x/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+IUSE="graphviz"
+
+DEPEND=""
+RDEPEND="graphviz? ( >=media-gfx/graphviz-5.0.0 )"
+BDEPEND="${PYTHON_DEPS}
+ dev-python/sphinx
+ dev-python/sphinx_rtd_theme
+ media-libs/fontconfig"
+
+src_prepare() {
+ default
+ # Fix the Python shebangs.
+ python_fix_shebang "${S}/Documentation/sphinx/"
+}
+
+src_compile() {
+ local ARCH="$(tc-arch-kernel)"
+ unset KBUILD_OUTPUT
+ HTML_DOCS=( Documentation/output/. )
+ emake htmldocs
+}
+
+src_install() {
+ einstalldocs
+}