summaryrefslogtreecommitdiff
path: root/sys-kernel/linux-docs/linux-docs-5.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-18 11:06:49 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-18 11:06:49 +0000
commitab3da91fb6c91a9df52fff8f991570f456fd3c7a (patch)
treee8f3bfa2c6c3d20ec3b9c352c839e23949068b6b /sys-kernel/linux-docs/linux-docs-5.10.0.ebuild
parent6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (diff)
gentoo resync : 18.12.2020
Diffstat (limited to 'sys-kernel/linux-docs/linux-docs-5.10.0.ebuild')
-rw-r--r--sys-kernel/linux-docs/linux-docs-5.10.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-kernel/linux-docs/linux-docs-5.10.0.ebuild b/sys-kernel/linux-docs/linux-docs-5.10.0.ebuild
new file mode 100644
index 000000000000..2b1d4fcb3da2
--- /dev/null
+++ b/sys-kernel/linux-docs/linux-docs-5.10.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+MY_PV="$(ver_cut 1-2)"
+MY_P=linux-${MY_PV}
+
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Developer documentation generated from the Linux kernel"
+HOMEPAGE="https://www.kernel.org/"
+SRC_URI="https://www.kernel.org/pub/linux/kernel/v5.x/${MY_P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+IUSE=""
+BDEPEND="media-libs/fontconfig"
+DEPEND="dev-python/sphinx"
+RDEPEND=""
+
+src_compile() {
+ local ARCH=$(tc-arch-kernel)
+ unset KBUILD_OUTPUT
+ emake htmldocs
+}
+
+src_install() {
+ HTML_DOCS=( Documentation/output/. )
+ einstalldocs
+}