summaryrefslogtreecommitdiff
path: root/sys-kernel/git-sources
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-30 08:49:38 +0100
commitb2be182d49eea46686b5cf2680d457df61e89dc4 (patch)
treec66442ced2011c5ca81c3114cc51041e314c6d33 /sys-kernel/git-sources
parente23cdda4dbb0c83b9e682ab5e916085a35203da5 (diff)
gentoo resync : 30.06.2018
Diffstat (limited to 'sys-kernel/git-sources')
-rw-r--r--sys-kernel/git-sources/Manifest2
-rw-r--r--sys-kernel/git-sources/git-sources-4.18_rc2.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 4e010ba6cda7..fc1a00f820c8 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -1,4 +1,6 @@
DIST linux-4.17.tar.xz 102165892 BLAKE2B b9e1fe2c063d2761b4d54594b841f6591fd6f5b634a402c07e0fa5518a2b271293d97c5a7a8e3c30c9c4d78df16bf20a4f0befe998c9a9393bb3290d2df1dda3 SHA512 4d9de340a26155a89ea8773131c76220cc2057f2b5d031b467b60e8b14c1842518e2d60a863d8c695f0f7640f3f18d43826201984a238dade857b6cef79837db
DIST patch-4.18-rc1.patch 52274025 BLAKE2B 8f3f9b01d981fbbdf4eb2b5857f8de305ccf434b3769d52bd029e98690f28ed82991001138bfbac38036b0c25bc491256647245b961ac90c1fedb693310ebbcb SHA512 3bf7227d5fc39d01f4be7706febde0973c3d8761457728bd0a01adb844954a9ef223d5d3f7c9a09132f6966cee0fe58ea72951363a96e7e8b579cf86da1ec8c6
+DIST patch-4.18-rc2.patch 52841801 BLAKE2B b9d65a0f2afb2f75b34ca3886cb2599cf85aa60eff943d9afacb5d708b131dfdb8956b357e6e94dc5e82f21f60135d887d6a1845edac0f0b3da1b5216c5f2a16 SHA512 1fdd5360543080f53d0889ce644818672c29a27850e1cf54cddaa3d4037ff91c01ac582dbfc7bb9a7b1e265c35f1c202145c44830a03feccfd807b13654c0e66
EBUILD git-sources-4.18_rc1.ebuild 1179 BLAKE2B 56d626a7ba8ae474be3595f25012e3bd74c51b56775b2fd9267049eb688958dd173a84ee6fabc3df7bb0ef965a19f857bade0029d3e1a83948829e0282caf2e5 SHA512 9f5a1b91752ec426c7b37bf60e3d7cc8b2e8cc8cc77173fd4edb0b46985ea42e244bcd97fb3924d6f635232335894b14193492ce29e11c1f0b39ca934cb50ca0
+EBUILD git-sources-4.18_rc2.ebuild 1179 BLAKE2B 56d626a7ba8ae474be3595f25012e3bd74c51b56775b2fd9267049eb688958dd173a84ee6fabc3df7bb0ef965a19f857bade0029d3e1a83948829e0282caf2e5 SHA512 9f5a1b91752ec426c7b37bf60e3d7cc8b2e8cc8cc77173fd4edb0b46985ea42e244bcd97fb3924d6f635232335894b14193492ce29e11c1f0b39ca934cb50ca0
MISC metadata.xml 596 BLAKE2B 967f959eca5873ccd58ab34aeabf965ec03e9ff41850fa4eb1c49f908ed7ad090ad2f5d7904f350c84cd47d99109e977835a2b216bb8605001b4098cdbdebda5 SHA512 c3476f5b64efc298e0df021b00dc4978a34ea48e5839a9cfee583291a4b5fe7ccc35db89a335db81e9c2cded36663691e6324dcabc90d0b287213d0fccddb227
diff --git a/sys-kernel/git-sources/git-sources-4.18_rc2.ebuild b/sys-kernel/git-sources/git-sources-4.18_rc2.ebuild
new file mode 100644
index 000000000000..25e1d9d7bdbe
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-4.18_rc2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="4.17"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}