summaryrefslogtreecommitdiff
path: root/sys-kernel/gentoo-sources/gentoo-sources-6.6.18.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-23 17:40:32 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-23 17:40:32 +0000
commit9aeefa0bd7e7604816f3ce08002112f9965176c3 (patch)
treea321bc3114ba3db3c2375bff886cc0b4e9a324b6 /sys-kernel/gentoo-sources/gentoo-sources-6.6.18.ebuild
parentedca36e835d0d4e929c1dd3e9688954ae0aa191a (diff)
gentoo auto-resync : 23:02:2024 - 17:40:32
Diffstat (limited to 'sys-kernel/gentoo-sources/gentoo-sources-6.6.18.ebuild')
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-6.6.18.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-6.6.18.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-6.6.18.ebuild
new file mode 100644
index 000000000000..97c30f1692db
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-6.6.18.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="24"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}