summaryrefslogtreecommitdiff
path: root/sys-kernel/gentoo-sources/gentoo-sources-5.10.188.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-27 16:34:32 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-27 16:34:32 +0100
commit1a7ba844ad2c84ac4ba0d37f510285e778c7ffc4 (patch)
tree6b0c029b423e831d2d4be3aea13954182623d7f4 /sys-kernel/gentoo-sources/gentoo-sources-5.10.188.ebuild
parenta12f416baa722b8bda57c0d527fb28b3d06b2aeb (diff)
gentoo auto-resync : 27:07:2023 - 16:34:32
Diffstat (limited to 'sys-kernel/gentoo-sources/gentoo-sources-5.10.188.ebuild')
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-5.10.188.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-5.10.188.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-5.10.188.ebuild
new file mode 100644
index 000000000000..79dffb978b86
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-5.10.188.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="198"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}