summaryrefslogtreecommitdiff
path: root/sys-kernel/gentoo-sources/gentoo-sources-5.10.164.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-18 17:57:26 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-18 17:57:26 +0000
commit220240f060e150ba4c4bb2d0f2a07f7c8f9de480 (patch)
treed6e25a202744ce994d341fab9d94c64053830068 /sys-kernel/gentoo-sources/gentoo-sources-5.10.164.ebuild
parent95b557bc48bb734c288bac87dcfe98b8ae3d1cdb (diff)
gentoo auto-resync : 18:01:2023 - 17:57:26
Diffstat (limited to 'sys-kernel/gentoo-sources/gentoo-sources-5.10.164.ebuild')
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-5.10.164.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-5.10.164.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-5.10.164.ebuild
new file mode 100644
index 000000000000..960da17e6c80
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-5.10.164.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="173"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}