summaryrefslogtreecommitdiff
path: root/sys-kernel/gentoo-sources/gentoo-sources-5.10.146.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-28 15:14:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-28 15:14:06 +0100
commite4faa07b4eb2f5e4f9756d33924b318b1349956a (patch)
tree0bb828f26b3f3dfe1bc3ec06cf3c67c6c32085d1 /sys-kernel/gentoo-sources/gentoo-sources-5.10.146.ebuild
parentc50fa1b9d54c15707ec744b80db6610da7dd7832 (diff)
gentoo auto-resync : 28:09:2022 - 15:13:59
Diffstat (limited to 'sys-kernel/gentoo-sources/gentoo-sources-5.10.146.ebuild')
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-5.10.146.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-5.10.146.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-5.10.146.ebuild
new file mode 100644
index 000000000000..e20a7b76acbe
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-5.10.146.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="155"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}