summaryrefslogtreecommitdiff
path: root/sys-kernel/dracut
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /sys-kernel/dracut
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'sys-kernel/dracut')
-rw-r--r--sys-kernel/dracut/Manifest3
-rw-r--r--sys-kernel/dracut/dracut-049-r2.ebuild157
-rw-r--r--sys-kernel/dracut/dracut-9999.ebuild1
3 files changed, 160 insertions, 1 deletions
diff --git a/sys-kernel/dracut/Manifest b/sys-kernel/dracut/Manifest
index 0ef0d516306d..759ab5588903 100644
--- a/sys-kernel/dracut/Manifest
+++ b/sys-kernel/dracut/Manifest
@@ -24,6 +24,7 @@ EBUILD dracut-047-r1.ebuild 4650 BLAKE2B 6847c8bc55aac1ccabaf258577a0cd07d749a54
EBUILD dracut-048-r1.ebuild 4541 BLAKE2B e9be5a23344987322fd1d8a00d17aaf41359664ec378da2c121d5537172c3f17e995127b451e2ff968408630a39913589fd76aa02b0a912075cc7c15a8f411ab SHA512 d112aace95b18abde2e1a6aaa9e3ac79338e5f951e5655a664f09137516b518589b221c0ee4a1aa2ad8ed10177fc5e09f32037af67f29d664faee4c422fa94fc
EBUILD dracut-048.ebuild 4467 BLAKE2B f6c816fac85d808363953c15cc73a7d6da99934129de297258114c6117a711b58aea818d568604215b3bfc7bf86934130c358701bb2380fd559d2bcd16fe69dc SHA512 11062f8ae2506bd54f6bb784c6c2be6416748fcd84a33554e4b58d66b87aea2b3324c2216a01a211e9bbd207e7e4065537cbcc5bd612b6aac46e2e0912ecec77
EBUILD dracut-049-r1.ebuild 4615 BLAKE2B ea43727ba91acd3a31b902dae3f80945957f1bbe5397c76bc3d46eb323ab5249b8edea1366c77253a792373d0cdc5ebb075484305dfafd86bbebccd9c0268bfb SHA512 bc0ac08a471ba994f9da4beb5ded4db2da8770e1a973d324e0b7b28845e357dde4401367defdc421c323103408318098386b9228c28e94de71b95c1726d802fa
+EBUILD dracut-049-r2.ebuild 4654 BLAKE2B 8d3da740bf354e82e6bfd155ea5858d21ce0904b255e83d43c70c9987152ea0027b797d19f59bae703e515ac6a4b04c9034fa770bcaf83de7e9f2c6cf002a743 SHA512 de9257ca8c56b065aaf104514670777159b5ad64005ab596c348765ae5b0e9c64e1f18ac3907c5f68cd9edef94385805ef1efe5256d1c78c420f4ef3fa02485c
EBUILD dracut-049.ebuild 4808 BLAKE2B 70418167cc13d508df24865d2c598dd208ce92963acc0c67b3106e24f3d97c8d82766cec91bbb475649b4003a2590f2279c663ff5b4b8785c3618c9bdca21f09 SHA512 cc9568f59f5d5be6605ff679cbaa55521beab37b7c9438fc096e4ceef7f194c6b21f35f1da177de17816eb7a1835bc27040b3ae21b3b31558e2606e7495e817b
-EBUILD dracut-9999.ebuild 4414 BLAKE2B 1c66e7ff9a12a1011112c4fbbf06930e6fd2593b3c75e71e1778818016e47dfb289b2ea1872013c8da684f5bb07ab9118a941c4152483a60932d2eec83a7b344 SHA512 659b3a626629778bbae1bdb3098a3743f6f9a5dffe41b4c6c095969a2b629294296dc723e6c151c383b5d15f92ccf6e9aaa95d5b452d87fe3acc28d8f0fbbfc7
+EBUILD dracut-9999.ebuild 4453 BLAKE2B 88879375ee46fb12f9c5ec8222d175e4ddce74b6ab2301af931242e961389fc1e239ae5346cfba223a28b4b1d6308ff8e4cf4c43d0286fe9d4078a54e0cc1f43 SHA512 5c60db3be8cec3c309549665dc84e425a87da53e23987b922409abd75fcaf6b236c3a5ab2a5dc90f6d128198c4414e5718d355822ad41b47d072f995d8e796cf
MISC metadata.xml 725 BLAKE2B 475d51f4e2bebf318ef94ea1fec40a34bcf04b4f0c69e051c8840e0965a92fd9861c5aa8acfb2ccb5a4cf354665ab3efc6adfdf7d0191325c1f798ea5e49594e SHA512 b708d0eb6a792d5ba3495f321af5e10672af3354f1f42c60b175b7fb48ae836e24db7768511c44cbb0a949c1cca75948890d3b32904bbe47e50d9c43d71787fb
diff --git a/sys-kernel/dracut/dracut-049-r2.ebuild b/sys-kernel/dracut/dracut-049-r2.ebuild
new file mode 100644
index 000000000000..872f2ff3a242
--- /dev/null
+++ b/sys-kernel/dracut/dracut-049-r2.ebuild
@@ -0,0 +1,157 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 eutils linux-info systemd toolchain-funcs
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dracutdevs/dracut"
+else
+ [[ "${PV}" = *_rc* ]] || \
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+ SRC_URI="https://github.com/dracutdevs/dracut/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="Generic initramfs generation tool"
+HOMEPAGE="https://dracut.wiki.kernel.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="selinux"
+
+# Tests need root privileges, bug #298014
+RESTRICT="test"
+
+RDEPEND="
+ app-arch/cpio
+ >=app-shells/bash-4.0:0
+ sys-apps/coreutils[xattr(-)]
+ >=sys-apps/kmod-23[tools]
+ || (
+ >=sys-apps/sysvinit-2.87-r3
+ sys-apps/openrc[sysv-utils,selinux?]
+ sys-apps/systemd[sysv-utils]
+ )
+ >=sys-apps/util-linux-2.21
+ virtual/pkgconfig
+ virtual/udev
+
+ selinux? (
+ sec-policy/selinux-dracut
+ sys-libs/libselinux
+ sys-libs/libsepol
+ )
+ "
+DEPEND=">=sys-apps/kmod-23"
+
+BDEPEND="
+ app-text/asciidoc
+ app-text/docbook-xml-dtd:4.5
+ >=app-text/docbook-xsl-stylesheets-1.75.2
+ >=dev-libs/libxslt-1.1.26
+ virtual/pkgconfig
+ "
+
+DOCS=( AUTHORS HACKING NEWS README README.generic README.kernel README.modules
+ README.testsuite TODO )
+
+QA_MULTILIB_PATHS="usr/lib/dracut/.*"
+
+PATCHES=(
+ "${FILESDIR}"/048-dracut-install-simplify-ldd-parsing-logic.patch
+ "${FILESDIR}"/049-40network-Don-t-include-40network-by-default.patch
+ "${FILESDIR}"/049-remove-bashism-in-various-boot-scripts.patch
+)
+
+src_configure() {
+ local myconf=(
+ --prefix="${EPREFIX}/usr"
+ --sysconfdir="${EPREFIX}/etc"
+ --bashcompletiondir="$(get_bashcompdir)"
+ --systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ )
+
+ tc-export CC PKG_CONFIG
+
+ echo ./configure "${myconf[@]}"
+ ./configure "${myconf[@]}" || die
+
+ if [[ ${PV} != 9999 ]] ; then
+ # Source tarball from github doesn't include this file
+ echo "DRACUT_VERSION=${PV}" > dracut-version.sh || die
+ fi
+}
+
+src_install() {
+ default
+
+ insinto /etc/logrotate.d
+ newins dracut.logrotate dracut
+
+ docinto html
+ dodoc dracut.html
+}
+
+pkg_postinst() {
+ if linux-info_get_any_version && linux_config_exists; then
+ ewarn ""
+ ewarn "If the following test report contains a missing kernel"
+ ewarn "configuration option, you should reconfigure and rebuild your"
+ ewarn "kernel before booting image generated with this Dracut version."
+ ewarn ""
+
+ local CONFIG_CHECK="~BLK_DEV_INITRD ~DEVTMPFS"
+
+ # Kernel configuration options descriptions:
+ local ERROR_DEVTMPFS='CONFIG_DEVTMPFS: "Maintain a devtmpfs filesystem to mount at /dev" '
+ ERROR_DEVTMPFS+='is missing and REQUIRED'
+ local ERROR_BLK_DEV_INITRD='CONFIG_BLK_DEV_INITRD: "Initial RAM filesystem and RAM disk '
+ ERROR_BLK_DEV_INITRD+='(initramfs/initrd) support" is missing and REQUIRED'
+
+ check_extra_config
+ echo
+ else
+ ewarn ""
+ ewarn "Your kernel configuration couldn't be checked."
+ ewarn "Please check manually if following options are enabled:"
+ ewarn ""
+ ewarn " CONFIG_BLK_DEV_INITRD"
+ ewarn " CONFIG_DEVTMPFS"
+ ewarn ""
+ fi
+
+ elog "To get additional features, a number of optional runtime"
+ elog "dependencies may be installed:"
+ elog ""
+ optfeature "Networking support" net-misc/networkmanager
+ optfeature "Legacy networking support" net-misc/curl "net-misc/dhcp[client]" \
+ sys-apps/iproute2 "net-misc/iputils[arping]"
+ optfeature \
+ "Measure performance of the boot process for later visualisation" \
+ app-benchmarks/bootchart2 app-admin/killproc sys-process/acct
+ optfeature "Scan for Btrfs on block devices" sys-fs/btrfs-progs
+ optfeature "Load kernel modules and drop this privilege for real init" \
+ sys-libs/libcap
+ optfeature "Support CIFS" net-fs/cifs-utils
+ optfeature "Decrypt devices encrypted with cryptsetup/LUKS" \
+ "sys-fs/cryptsetup[-static-libs]"
+ optfeature "Support for GPG-encrypted keys for crypt module" \
+ app-crypt/gnupg
+ optfeature \
+ "Allows use of dash instead of default bash (on your own risk)" \
+ app-shells/dash
+ optfeature "Support iSCSI" sys-block/open-iscsi
+ optfeature "Support Logical Volume Manager" sys-fs/lvm2
+ optfeature "Support MD devices, also known as software RAID devices" \
+ sys-fs/mdadm
+ optfeature "Support Device Mapper multipathing" sys-fs/multipath-tools
+ optfeature "Plymouth boot splash" '>=sys-boot/plymouth-0.8.5-r5'
+ optfeature "Support network block devices" sys-block/nbd
+ optfeature "Support NFS" net-fs/nfs-utils net-nds/rpcbind
+ optfeature \
+ "Install ssh and scp along with config files and specified keys" \
+ net-misc/openssh
+ optfeature "Enable logging with rsyslog" app-admin/rsyslog
+}
diff --git a/sys-kernel/dracut/dracut-9999.ebuild b/sys-kernel/dracut/dracut-9999.ebuild
index d271f1a2dd3a..8cd97656094e 100644
--- a/sys-kernel/dracut/dracut-9999.ebuild
+++ b/sys-kernel/dracut/dracut-9999.ebuild
@@ -31,6 +31,7 @@ RDEPEND="
>=sys-apps/kmod-23[tools]
|| (
>=sys-apps/sysvinit-2.87-r3
+ sys-apps/openrc[sysv-utils,selinux?]
sys-apps/systemd[sysv-utils]
)
>=sys-apps/util-linux-2.21