summaryrefslogtreecommitdiff
path: root/sys-kernel/dracut
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-31 16:00:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-31 16:00:27 +0000
commit1db00cc6e94b90c08090bb5b8c406622946c4ae5 (patch)
treec34bf820c2809fb7e08ed5564df2a25cf759516f /sys-kernel/dracut
parent693cc9b6e847a01c1bb692153021aaf9fb0fab25 (diff)
gentoo resync 31.01.2019
Diffstat (limited to 'sys-kernel/dracut')
-rw-r--r--sys-kernel/dracut/Manifest3
-rw-r--r--sys-kernel/dracut/dracut-049-r1.ebuild156
-rw-r--r--sys-kernel/dracut/dracut-9999.ebuild11
3 files changed, 158 insertions, 12 deletions
diff --git a/sys-kernel/dracut/Manifest b/sys-kernel/dracut/Manifest
index f8925705715b..d41c94d16927 100644
--- a/sys-kernel/dracut/Manifest
+++ b/sys-kernel/dracut/Manifest
@@ -23,6 +23,7 @@ EBUILD dracut-046-r1.ebuild 4721 BLAKE2B 88e0b0fad86e6cd97ed38ba86704c483d3685f2
EBUILD dracut-047-r1.ebuild 4650 BLAKE2B 6847c8bc55aac1ccabaf258577a0cd07d749a54c27db9338d845db1905974b5a419f88b2f76c5769d5765e01a714c4de3bebf953625a4473f0cb0373d2e157af SHA512 c20892b9c02e27c9c3af59abef2adb90d3410fe889f82e1a74855ff3e87d3865483728d53a9898c82fac8824409ac3a1c65f23f53c0e63491a7cbcc5855b64f4
EBUILD dracut-048-r1.ebuild 4547 BLAKE2B 891990985f6b459377f94811840774b86e01225b6996055ad050e7bc71331f7d10494f7fc514cf13df68dc3441b4726023bc871e8b50558c88db528289158c96 SHA512 3576ec29ad05c2bec9406b21dba1e207491a2cb9e7d054d522affc4501020280e2fe3357f6d283ea4c2cd9770ec4d5e2fa6d73bae86597d736da5db1f3e0c510
EBUILD dracut-048.ebuild 4467 BLAKE2B f6c816fac85d808363953c15cc73a7d6da99934129de297258114c6117a711b58aea818d568604215b3bfc7bf86934130c358701bb2380fd559d2bcd16fe69dc SHA512 11062f8ae2506bd54f6bb784c6c2be6416748fcd84a33554e4b58d66b87aea2b3324c2216a01a211e9bbd207e7e4065537cbcc5bd612b6aac46e2e0912ecec77
+EBUILD dracut-049-r1.ebuild 4608 BLAKE2B ef723d0d0de4492297fb64e55900052b394185bd5ea13cd0a2f8c76097358d88f4099b36761f6c52e061e7cab450e86f1dd2a6130d2fe30001368863da46a1c0 SHA512 db762da656abcb3be668cf0364fb37bf188084fb6fb43538d1243c29f29abaa37e26d9ff14f1fa817bead8fbfff3543af24b47752afb241b260ad28927139c45
EBUILD dracut-049.ebuild 4808 BLAKE2B 70418167cc13d508df24865d2c598dd208ce92963acc0c67b3106e24f3d97c8d82766cec91bbb475649b4003a2590f2279c663ff5b4b8785c3618c9bdca21f09 SHA512 cc9568f59f5d5be6605ff679cbaa55521beab37b7c9438fc096e4ceef7f194c6b21f35f1da177de17816eb7a1835bc27040b3ae21b3b31558e2606e7495e817b
-EBUILD dracut-9999.ebuild 4783 BLAKE2B 977f72c78abe1e4e7275ab877b88c62349daecf529f4512b65296321f83a275c87398e2815402e8cee8b817afed2c1e54fe0f548d3c53d665f277ad352f61a6c SHA512 7d5cbd7ca1ee591e9521d0242286e983e40c4579c8aaa1e1a4be0fbb50ea044f90c32a06c8df3a1f131d8ff4c70804475c21ec1d64904587ca2d66f36fc90322
+EBUILD dracut-9999.ebuild 4407 BLAKE2B 351a1c88eb87f917c21528e2b1cef687b56cf5efac983ac6b62ee5cec58d23c512b8476b3b5f50d757941c4cec92b6be824b1591a66b895f0ac7e9fdbc25c89c SHA512 504621dd47df55274f0f725eb1f6af70276404e12fef15d047e4a36ba5cca356859fd2a69dfb0405f2f6ab105b29b76cbfbce9b225e40121e6063fbb614dc92b
MISC metadata.xml 725 BLAKE2B 475d51f4e2bebf318ef94ea1fec40a34bcf04b4f0c69e051c8840e0965a92fd9861c5aa8acfb2ccb5a4cf354665ab3efc6adfdf7d0191325c1f798ea5e49594e SHA512 b708d0eb6a792d5ba3495f321af5e10672af3354f1f42c60b175b7fb48ae836e24db7768511c44cbb0a949c1cca75948890d3b32904bbe47e50d9c43d71787fb
diff --git a/sys-kernel/dracut/dracut-049-r1.ebuild b/sys-kernel/dracut/dracut-049-r1.ebuild
new file mode 100644
index 000000000000..840818b1317b
--- /dev/null
+++ b/sys-kernel/dracut/dracut-049-r1.ebuild
@@ -0,0 +1,156 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 eutils linux-info systemd toolchain-funcs
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dracutdevs/dracut"
+else
+ [[ "${PV}" = *_rc* ]] || \
+ KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+ SRC_URI="https://github.com/dracutdevs/dracut/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="Generic initramfs generation tool"
+HOMEPAGE="https://dracut.wiki.kernel.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="selinux"
+
+# Tests need root privileges, bug #298014
+RESTRICT="test"
+
+RDEPEND="
+ app-arch/cpio
+ >=app-shells/bash-4.0:0
+ sys-apps/coreutils[xattr(-)]
+ >=sys-apps/kmod-23[tools]
+ || (
+ >=sys-apps/sysvinit-2.87-r3
+ sys-apps/systemd[sysv-utils]
+ )
+ >=sys-apps/util-linux-2.21
+ virtual/pkgconfig
+ virtual/udev
+
+ selinux? (
+ sec-policy/selinux-dracut
+ sys-libs/libselinux
+ sys-libs/libsepol
+ )
+ "
+DEPEND=">=sys-apps/kmod-23"
+
+BDEPEND="
+ app-text/asciidoc
+ app-text/docbook-xml-dtd:4.5
+ >=app-text/docbook-xsl-stylesheets-1.75.2
+ >=dev-libs/libxslt-1.1.26
+ virtual/pkgconfig
+ "
+
+DOCS=( AUTHORS HACKING NEWS README README.generic README.kernel README.modules
+ README.testsuite TODO )
+
+QA_MULTILIB_PATHS="usr/lib/dracut/.*"
+
+PATCHES=(
+ "${FILESDIR}"/048-dracut-install-simplify-ldd-parsing-logic.patch
+ "${FILESDIR}"/049-40network-Don-t-include-40network-by-default.patch
+ "${FILESDIR}"/049-remove-bashism-in-various-boot-scripts.patch
+)
+
+src_configure() {
+ local myconf=(
+ --prefix="${EPREFIX}/usr"
+ --sysconfdir="${EPREFIX}/etc"
+ --bashcompletiondir="$(get_bashcompdir)"
+ --systemdsystemunitdir="$(systemd_get_systemunitdir)"
+ )
+
+ tc-export CC PKG_CONFIG
+
+ echo ./configure "${myconf[@]}"
+ ./configure "${myconf[@]}" || die
+
+ if [[ ${PV} != 9999 ]] ; then
+ # Source tarball from github doesn't include this file
+ echo "DRACUT_VERSION=${PV}" > dracut-version.sh || die
+ fi
+}
+
+src_install() {
+ default
+
+ insinto /etc/logrotate.d
+ newins dracut.logrotate dracut
+
+ docinto html
+ dodoc dracut.html
+}
+
+pkg_postinst() {
+ if linux-info_get_any_version && linux_config_exists; then
+ ewarn ""
+ ewarn "If the following test report contains a missing kernel"
+ ewarn "configuration option, you should reconfigure and rebuild your"
+ ewarn "kernel before booting image generated with this Dracut version."
+ ewarn ""
+
+ local CONFIG_CHECK="~BLK_DEV_INITRD ~DEVTMPFS"
+
+ # Kernel configuration options descriptions:
+ local ERROR_DEVTMPFS='CONFIG_DEVTMPFS: "Maintain a devtmpfs filesystem to mount at /dev" '
+ ERROR_DEVTMPFS+='is missing and REQUIRED'
+ local ERROR_BLK_DEV_INITRD='CONFIG_BLK_DEV_INITRD: "Initial RAM filesystem and RAM disk '
+ ERROR_BLK_DEV_INITRD+='(initramfs/initrd) support" is missing and REQUIRED'
+
+ check_extra_config
+ echo
+ else
+ ewarn ""
+ ewarn "Your kernel configuration couldn't be checked."
+ ewarn "Please check manually if following options are enabled:"
+ ewarn ""
+ ewarn " CONFIG_BLK_DEV_INITRD"
+ ewarn " CONFIG_DEVTMPFS"
+ ewarn ""
+ fi
+
+ elog "To get additional features, a number of optional runtime"
+ elog "dependencies may be installed:"
+ elog ""
+ optfeature "Networking support" net-misc/networkmanager
+ optfeature "Legacy networking support" net-misc/curl "net-misc/dhcp[client]" \
+ sys-apps/iproute2 "net-misc/iputils[arping]"
+ optfeature \
+ "Measure performance of the boot process for later visualisation" \
+ app-benchmarks/bootchart2 app-admin/killproc sys-process/acct
+ optfeature "Scan for Btrfs on block devices" sys-fs/btrfs-progs
+ optfeature "Load kernel modules and drop this privilege for real init" \
+ sys-libs/libcap
+ optfeature "Support CIFS" net-fs/cifs-utils
+ optfeature "Decrypt devices encrypted with cryptsetup/LUKS" \
+ "sys-fs/cryptsetup[-static-libs]"
+ optfeature "Support for GPG-encrypted keys for crypt module" \
+ app-crypt/gnupg
+ optfeature \
+ "Allows use of dash instead of default bash (on your own risk)" \
+ app-shells/dash
+ optfeature "Support iSCSI" sys-block/open-iscsi
+ optfeature "Support Logical Volume Manager" sys-fs/lvm2
+ optfeature "Support MD devices, also known as software RAID devices" \
+ sys-fs/mdadm
+ optfeature "Support Device Mapper multipathing" sys-fs/multipath-tools
+ optfeature "Plymouth boot splash" '>=sys-boot/plymouth-0.8.5-r5'
+ optfeature "Support network block devices" sys-block/nbd
+ optfeature "Support NFS" net-fs/nfs-utils net-nds/rpcbind
+ optfeature \
+ "Install ssh and scp along with config files and specified keys" \
+ net-misc/openssh
+ optfeature "Enable logging with rsyslog" app-admin/rsyslog
+}
diff --git a/sys-kernel/dracut/dracut-9999.ebuild b/sys-kernel/dracut/dracut-9999.ebuild
index 7ccd4d0b0e56..67bf16fda20e 100644
--- a/sys-kernel/dracut/dracut-9999.ebuild
+++ b/sys-kernel/dracut/dracut-9999.ebuild
@@ -83,17 +83,6 @@ src_configure() {
src_install() {
default
- local libdirs=( /$(get_libdir) /usr/$(get_libdir) )
- if [[ ${SYMLINK_LIB} = yes && $(get_libdir) != lib ]]; then
- # Preserve lib -> lib64 symlinks in initramfs
- libdirs+=( /lib /usr/lib )
- fi
-
- einfo "Setting libdirs to \"${libdirs[*]}\" ..."
- echo "libdirs=\"${libdirs[*]}\"" > "${T}/gentoo.conf" || die
- insinto "/usr/lib/dracut/dracut.conf.d"
- doins "${T}/gentoo.conf"
-
insinto /etc/logrotate.d
newins dracut.logrotate dracut