summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-10 10:42:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-10 10:42:05 +0100
commit946859e0e36904cffb3e0ccbccb6b7b1347c1cc8 (patch)
tree0acec77e64f765c013ceda868659a8e125e429df /sys-fs
parentb9baffd9af9383cc886b1583814fe15163017d80 (diff)
gentoo auto-resync : 10:09:2022 - 10:42:05
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/Manifest.gzbin22235 -> 22236 bytes
-rw-r--r--sys-fs/lxcfs/Manifest1
-rw-r--r--sys-fs/lxcfs/lxcfs-5.0.2.ebuild77
3 files changed, 0 insertions, 78 deletions
diff --git a/sys-fs/Manifest.gz b/sys-fs/Manifest.gz
index 73ef99cb1762..e14a28dbeeba 100644
--- a/sys-fs/Manifest.gz
+++ b/sys-fs/Manifest.gz
Binary files differ
diff --git a/sys-fs/lxcfs/Manifest b/sys-fs/lxcfs/Manifest
index 2d2dbc07a44a..84b4263955a0 100644
--- a/sys-fs/lxcfs/Manifest
+++ b/sys-fs/lxcfs/Manifest
@@ -9,5 +9,4 @@ DIST lxcfs-5.0.2.tar.gz 103236 BLAKE2B 5fc8dc437e97a79c78320f8d8111746b171b086be
DIST lxcfs-5.0.2.tar.gz.asc 833 BLAKE2B a411c6cb4f3382469ea80a974166c98b57ae4b92712bf55507720fc78ec73ef6acbd47f6b3410294b209f77f1f3a17dc4b9fb4dda00bb7323ef32c7185ba4c2e SHA512 f9d54e26d406ebca97c82298361318f13e74fd55285c2b6563ae6c71af63d9b8325ac06b9de8103a95a19c5d965c2d907c313ac151210a162998f8a37ea99676
EBUILD lxcfs-5.0.0_p20220524.ebuild 1728 BLAKE2B 0b357a0906f9f7921d99948ce1721d4f6e3e076f3367ed2eae91078c4c71d20611cb49dad2c446675e200dd1e0060b06fbcadf304911145c1aae78f639b665b1 SHA512 67890b74409da3767b9169b727fc895fd4345abc62190414ee4ca3cb22fee4b24cdbe240b2c73162e99d0c0ce18a3eb340d91a6993c794ac6266f8fa898d4fe6
EBUILD lxcfs-5.0.2-r1.ebuild 1848 BLAKE2B 35ac744020136ea5b8537b2f7a7b2550a08c45ae2009364e5111abe3fea1d25731c376cbd49874446501675f97dc47ccf73e0cd9a8d4dd9aa8a82c611dfe9f99 SHA512 eedef4f780da3ca12378f578129f8041ec15831b470b152c876fc64817cde712e50f782311fce06bc4b08fd51dabd3c57d74ae5dea0e9be39cc09781730ea5c8
-EBUILD lxcfs-5.0.2.ebuild 1848 BLAKE2B 4bcf1691ede06337d5ee98ec1d5978d46532ff31fa3182d1aa93850e4c5740d0c71977188461a18b5dbf5819c60c9baff16812c34d5171c5e7f53005cd154f4f SHA512 6be20bb6e6fbc1f19e3e56a93717ebb3ab370835e7855145f3b06d7c8c2522768ed0844c4a833956a7d99291da9b1f33ca4b76146654d46ed55ae9626a1eb179
MISC metadata.xml 710 BLAKE2B ac2111d3b67e2aa7286b98e3069e77e3b852f401b56a921795370febd8836434e13cfec4af92cc83a379037023c3d7af475516bea02545595fe9a58a188dcb2f SHA512 f07ff1acbf28cda31d9d962332ecf473197d2868488e7051185ab5ab792f5bb9405712d68e3f9c3b10f38024d2025784b98ce9513e2978f537c26bc7c4d7caab
diff --git a/sys-fs/lxcfs/lxcfs-5.0.2.ebuild b/sys-fs/lxcfs/lxcfs-5.0.2.ebuild
deleted file mode 100644
index 9af4475e9807..000000000000
--- a/sys-fs/lxcfs/lxcfs-5.0.2.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit cmake meson python-any-r1 systemd verify-sig
-
-DESCRIPTION="FUSE filesystem for LXC"
-HOMEPAGE="https://linuxcontainers.org/lxcfs/introduction/ https://github.com/lxc/lxcfs/"
-SRC_URI="https://linuxcontainers.org/downloads/lxcfs/${P}.tar.gz
- verify-sig? ( https://linuxcontainers.org/downloads/lxcfs/${P}.tar.gz.asc )"
-
-LICENSE="Apache-2.0 LGPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
-IUSE="doc test"
-
-DEPEND="sys-fs/fuse:3"
-RDEPEND="${DEPEND}"
-BDEPEND="${PYTHON_DEPS}
- $(python_gen_any_dep '
- dev-python/jinja[${PYTHON_USEDEP}]
- ')
- doc? ( sys-apps/help2man )
- verify-sig? ( sec-keys/openpgp-keys-linuxcontainers )"
-
-# Needs some black magic to work inside container/chroot.
-RESTRICT="test"
-
-VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/linuxcontainers.asc
-
-python_check_deps() {
- python_has_version -b "dev-python/jinja[${PYTHON_USEDEP}]"
-}
-
-pkg_setup() {
- python-any-r1_pkg_setup
-}
-
-src_prepare() {
- default
-
- # Fix python shebangs for python-exec[-native-symlinks], #851480
- local shebangs=($(grep -rl "#!/usr/bin/env python3" || die))
- python_fix_shebang -q ${shebangs[*]}
-}
-
-src_configure() {
- local emesonargs=(
- $(meson_use doc docs)
- $(meson_use test tests)
-
- -Dfuse-version=3
- -Dinit-script=""
- -Dwith-init-script=""
- )
-
- meson_src_configure
-}
-
-src_test() {
- cd "${BUILD_DIR}"/tests || die "failed to change into tests/ directory."
- ./main.sh || die
-}
-
-src_install() {
- meson_src_install
-
- newconfd "${FILESDIR}"/lxcfs-4.0.0.confd lxcfs
- newinitd "${FILESDIR}"/lxcfs-4.0.0.initd lxcfs
-
- # Provide our own service file (copy of upstream) due to paths being different from upstream,
- # #728470
- systemd_newunit "${FILESDIR}"/lxcfs-4.0.0.service lxcfs.service
-}