summaryrefslogtreecommitdiff
path: root/sys-fs/zfs/zfs-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /sys-fs/zfs/zfs-9999.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'sys-fs/zfs/zfs-9999.ebuild')
-rw-r--r--sys-fs/zfs/zfs-9999.ebuild12
1 files changed, 3 insertions, 9 deletions
diff --git a/sys-fs/zfs/zfs-9999.ebuild b/sys-fs/zfs/zfs-9999.ebuild
index 27dbc2a09a0a..c7cc180b9ea0 100644
--- a/sys-fs/zfs/zfs-9999.ebuild
+++ b/sys-fs/zfs/zfs-9999.ebuild
@@ -6,13 +6,13 @@ EAPI=7
DISTUTILS_OPTIONAL=1
PYTHON_COMPAT=( python3_{6,7} )
-inherit bash-completion-r1 flag-o-matic linux-info distutils-r1 systemd toolchain-funcs udev usr-ldscript
+inherit autotools bash-completion-r1 flag-o-matic linux-info distutils-r1 systemd toolchain-funcs udev usr-ldscript
DESCRIPTION="Userland utilities for ZFS Linux kernel module"
HOMEPAGE="https://github.com/openzfs/zfs"
if [[ ${PV} == "9999" ]] ; then
- inherit autotools git-r3 linux-mod
+ inherit git-r3 linux-mod
EGIT_REPO_URI="https://github.com/openzfs/zfs.git"
else
SRC_URI="https://github.com/openzfs/${PN}/releases/download/${P}/${P}.tar.gz"
@@ -110,7 +110,7 @@ src_prepare() {
# prevent errors showing up on zfs-mount stop, #647688
# openrc will unmount all filesystems anyway.
- sed -i "/^ZFS_UNMOUNT=/ s/yes/no/" etc/default/zfs.in || die
+ sed -i "/^ZFS_UNMOUNT=/ s/yes/no/" "etc/default/zfs.in" || die
}
src_configure() {
@@ -184,12 +184,6 @@ pkg_postinst() {
elog " sys-kernel/dracut"
elog " sys-kernel/genkernel"
fi
-
- if has_version "<=sys-kernel/genkernel-3.5.3.3"; then
- einfo "genkernel version 3.5.3.3 and earlier does NOT support"
- einfo " unlocking pools with native zfs encryption enabled at boot"
- einfo " use dracut or >=genkernel-4 if you requre this functionality"
- fi
fi
if ! use kernel-builtin && [[ ${PV} = "9999" ]]; then