summaryrefslogtreecommitdiff
path: root/sys-fs/zfs/zfs-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /sys-fs/zfs/zfs-9999.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'sys-fs/zfs/zfs-9999.ebuild')
-rw-r--r--sys-fs/zfs/zfs-9999.ebuild32
1 files changed, 21 insertions, 11 deletions
diff --git a/sys-fs/zfs/zfs-9999.ebuild b/sys-fs/zfs/zfs-9999.ebuild
index 1d1a3c6ccc7c..d4e6a719e7dc 100644
--- a/sys-fs/zfs/zfs-9999.ebuild
+++ b/sys-fs/zfs/zfs-9999.ebuild
@@ -11,27 +11,33 @@ inherit autotools bash-completion-r1 distutils-r1 flag-o-matic linux-info pam sy
DESCRIPTION="Userland utilities for ZFS Linux kernel module"
HOMEPAGE="https://github.com/openzfs/zfs"
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == "9999" ]]; then
inherit git-r3 linux-mod
EGIT_REPO_URI="https://github.com/openzfs/zfs.git"
else
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/openzfs.asc
+ inherit verify-sig
+
MY_P="${P/_rc/-rc}"
SRC_URI="https://github.com/openzfs/${PN}/releases/download/${MY_P}/${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~ppc64"
+ SRC_URI+=" verify-sig? ( https://github.com/openzfs/${PN}/releases/download/${MY_P}/${MY_P}.tar.gz.asc )"
S="${WORKDIR}/${P%_rc?}"
+
+ if [[ ${PV} != *_rc* ]]; then
+ KEYWORDS="~amd64 ~arm64 ~ppc64"
+ fi
fi
LICENSE="BSD-2 CDDL MIT"
# just libzfs soname major for now.
# possible candidates: libuutil, libzpool, libnvpair. Those do not provide stable abi, but are considered.
-SLOT="0/4"
+SLOT="0/5"
IUSE="custom-cflags debug kernel-builtin libressl minimal nls pam python +rootfs test-suite static-libs"
DEPEND="
net-libs/libtirpc[static-libs?]
sys-apps/util-linux[static-libs?]
sys-libs/zlib[static-libs(+)?]
- virtual/awk
virtual/libudev[static-libs(-)?]
libressl? ( dev-libs/libressl:0=[static-libs?] )
!libressl? ( dev-libs/openssl:0=[static-libs?] )
@@ -50,10 +56,16 @@ BDEPEND="virtual/awk
)
"
+if [[ ${PV} != "9999" ]] ; then
+ BDEPEND+=" verify-sig? ( app-crypt/openpgp-keys-openzfs )"
+fi
+
+# awk is used for some scripts, completions, and the Dracut module
RDEPEND="${DEPEND}
!kernel-builtin? ( ~sys-fs/zfs-kmod-${PV} )
!prefix? ( virtual/udev )
sys-fs/udev-init-scripts
+ virtual/awk
rootfs? (
app-arch/cpio
app-misc/pax-utils
@@ -78,13 +90,11 @@ REQUIRED_USE="
RESTRICT="test"
-PATCHES=( "${FILESDIR}/bash-completion-sudo.patch" )
-
pkg_setup() {
if use kernel_linux && use test-suite; then
linux-info_pkg_setup
- if ! linux_config_exists; then
+ if ! linux_config_exists; then
ewarn "Cannot check the linux kernel configuration."
else
if use test-suite; then
@@ -174,7 +184,7 @@ src_install() {
use test-suite || { rm -r "${ED}/usr/share/zfs" || die ; }
if ! use static-libs; then
- find "${ED}/" -name '*.la' -delete || die
+ find "${ED}" -name '*.la' -delete || die
fi
dobashcomp contrib/bash_completion.d/zfs
@@ -196,14 +206,14 @@ src_install() {
pkg_postinst() {
if use rootfs; then
if ! has_version sys-kernel/genkernel && ! has_version sys-kernel/dracut; then
- elog "root on zfs requires initramfs to boot"
- elog "the following packages known to provide one and tested on regular basis:"
+ elog "Root on zfs requires an initramfs to boot"
+ elog "The following packages provide one and are tested on a regular basis:"
elog " sys-kernel/dracut"
elog " sys-kernel/genkernel"
fi
fi
- if ! use kernel-builtin && [[ ${PV} = "9999" ]]; then
+ if ! use kernel-builtin && [[ ${PV} == "9999" ]]; then
einfo "Adding ${P} to the module database to ensure that the"
einfo "kernel modules and userland utilities stay in sync."
update_moduledb