summaryrefslogtreecommitdiff
path: root/sys-fs/zfs-kmod/zfs-kmod-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-02 08:55:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-02 08:55:38 +0000
commit5a1e5a6812ca9c9555657cce48fe09d2ffa44401 (patch)
tree5c040bbee9184b24f26b05031a2448e62f6df38a /sys-fs/zfs-kmod/zfs-kmod-9999.ebuild
parent2c4066122b66fa1eb3e37846f9a6e14529a553d8 (diff)
gentoo auto-resync : 02:12:2022 - 08:55:37
Diffstat (limited to 'sys-fs/zfs-kmod/zfs-kmod-9999.ebuild')
-rw-r--r--sys-fs/zfs-kmod/zfs-kmod-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sys-fs/zfs-kmod/zfs-kmod-9999.ebuild b/sys-fs/zfs-kmod/zfs-kmod-9999.ebuild
index 8edf8733327b..b2fa04c9966a 100644
--- a/sys-fs/zfs-kmod/zfs-kmod-9999.ebuild
+++ b/sys-fs/zfs-kmod/zfs-kmod-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools dist-kernel-utils flag-o-matic linux-mod toolchain-funcs
@@ -21,12 +21,12 @@ else
S="${WORKDIR}/zfs-${PV%_rc?}"
ZFS_KERNEL_COMPAT="6.0"
- # increments minor eg 5.14 -> 5.15, and still supports override.
+ # increments minor eg 5.14 -> 5.15, and still supports override.
ZFS_KERNEL_DEP="${ZFS_KERNEL_COMPAT_OVERRIDE:-${ZFS_KERNEL_COMPAT}}"
ZFS_KERNEL_DEP="${ZFS_KERNEL_DEP%%.*}.$(( ${ZFS_KERNEL_DEP##*.} + 1))"
if [[ ${PV} != *_rc* ]]; then
- KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~sparc"
fi
fi
@@ -38,7 +38,7 @@ RDEPEND="${DEPEND}"
BDEPEND="
dev-lang/perl
- virtual/awk
+ app-alternatives/awk
"
# we want dist-kernel block in BDEPEND because of portage resolver.