summaryrefslogtreecommitdiff
path: root/sys-fs/vhba
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-fs/vhba
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-fs/vhba')
-rw-r--r--sys-fs/vhba/Manifest5
-rw-r--r--sys-fs/vhba/metadata.xml11
-rw-r--r--sys-fs/vhba/vhba-20170610.ebuild81
3 files changed, 97 insertions, 0 deletions
diff --git a/sys-fs/vhba/Manifest b/sys-fs/vhba/Manifest
new file mode 100644
index 000000000000..fc607b6ace32
--- /dev/null
+++ b/sys-fs/vhba/Manifest
@@ -0,0 +1,5 @@
+DIST vhba-module-20170610.tar.bz2 15622 SHA256 7970c93f989d9c4f2629371bf5ee7a76f95e4c12342c3320ddc528d0df02d9ec SHA512 bf27a6a7a6aabf6c1a4c1f16b1a08dce460ee675ea53b141c6db8edf0637dffa900e03b9141f9f1a672fcd8f84e6f2be86a07e1f78bc5667a7a7669d45f1f687 WHIRLPOOL b5e9c8ae140e7267d11c3bab71879f49c3be464504193e06c8a77d291f22c41d9c017a8dc06477566b89b89430305aee71c2542a2d3ce04783f7f08e7122e730
+EBUILD vhba-20170610.ebuild 2155 SHA256 105979ffb558ae15ec84a60ea4745ad61d8929484d65d0d695488751513bc940 SHA512 06dcdbd12d4db2483ca3af4212c867ddfbaaf6559deb713f0bf39fd50843071f544711c947fa12421169031fd3a4753fa6e8a96dc454c09f32331c75fbc282cf WHIRLPOOL 2d1fba09260138e497c25180f18e042310159fe7a4909bb34eaad6f4b2b94b2527cb091be4147c09a6635b9221c53e04374bfcff3b70e5dcdd453866714b553e
+MISC ChangeLog 2223 SHA256 95103825c91e41e52b0444c06bf8063dc8fe4eed1c9c6190f25553d68aabadac SHA512 8086b221a0d81b58d6b382d440857f4ca9e4267abc092f4cde9f1ec15e831d07c3b919b9f30789fb46066fc291d53122035cccfdaa0c8506a19b48f5bb33686e WHIRLPOOL 9ed3ca1e851d012d9167b6b6009e73a167f8f3855fecf0634392014f9fe1761e408a7176ee3a5041bb9854f15145ec52fae593311d32304a0fb07ad921c6f352
+MISC ChangeLog-2015 9270 SHA256 65e862c1b00416b8a70993142d9296f6016af79493b785937ffbc913531c746e SHA512 95dd3b7ed47c0c7d90ce7cfe07d7f40d29f923c0e153cb200d9e21b1abb72ea79e142bfd7d29fe5527975038b9fb9bcc271c274a4ccc8c309301c73072dc0ed9 WHIRLPOOL 3168b943cd3b17e62e8e5776df2e98ba5b9ae633e717ae3d1c4eb71e73299831d21246021a955cc56a9f4b7854120004e46e4994b8b16663ebd4ea03e89b55f2
+MISC metadata.xml 341 SHA256 d78aa5c3586fa7c6c026a836bfc00dce3212f1871d597b786113c30436722bc0 SHA512 a401a5cdb6f7cc87654f66a5617246f081840d8dbadf376f8590d55c1ab528e79cbe1708d58e41bf1ed104ababcfda79da69595a107e0236ccaa974144304e09 WHIRLPOOL 0e82c3cc150273143ade85d07180057c6533edc365f0d63a808f706fec43210d0905862d59ee729149471e8f9c514091a8e3db7f86a8a70b072b9c5f92a5663e
diff --git a/sys-fs/vhba/metadata.xml b/sys-fs/vhba/metadata.xml
new file mode 100644
index 000000000000..f998f663a174
--- /dev/null
+++ b/sys-fs/vhba/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tetromino@gentoo.org</email>
+ <name>Alexandre Rostovtsev</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">cdemu</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-fs/vhba/vhba-20170610.ebuild b/sys-fs/vhba/vhba-20170610.ebuild
new file mode 100644
index 000000000000..ffb1252014db
--- /dev/null
+++ b/sys-fs/vhba/vhba-20170610.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit eutils linux-mod udev
+
+MY_P=vhba-module-${PV}
+DESCRIPTION="Virtual (SCSI) Host Bus Adapter kernel module for the CDEmu suite"
+HOMEPAGE="http://cdemu.org"
+SRC_URI="mirror://sourceforge/cdemu/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ~hppa x86"
+IUSE=""
+
+RDEPEND="virtual/udev"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+MODULE_NAMES="vhba(block:${S})"
+BUILD_TARGETS=modules
+
+pkg_setup() {
+ CONFIG_CHECK="~BLK_DEV_SR ~CHR_DEV_SG"
+ check_extra_config
+ BUILD_PARAMS="KDIR=${KV_OUT_DIR}"
+ linux-mod_pkg_setup
+}
+
+src_prepare() {
+ # Avoid "make jobserver unavailable" warning and -Werror problems
+ sed -e '/ccflags/s/-Werror$/-Wall/' \
+ -i Makefile || die "sed failed"
+
+ eapply_user
+}
+
+src_install() {
+ dodoc AUTHORS ChangeLog README
+ linux-mod_src_install
+
+ einfo "Generating udev rules ..."
+ dodir "$(get_udevdir)"/rules.d
+ cat > "${D}/$(get_udevdir)"/rules.d/69-vhba.rules <<-EOF || die
+ # do not edit this file, it will be overwritten on update
+ #
+ KERNEL=="vhba_ctl", SUBSYSTEM=="misc", TAG+="uaccess"
+ EOF
+}
+
+pkg_postinst() {
+ # Older versions of vhba installed their rule file in /etc/udev/rules.d,
+ # which overrides rules in /lib/udev/rules.d. We remove the old file
+ # automatically if it is identical to the default one installed by
+ # vhba-1.2.1 or 20101015-r1. Note that the comment at the top of the rules
+ # file states that it can be automatically overwritten by the system.
+ old_rules="${ROOT}etc/udev/rules.d/70-vhba.rules"
+ if [[ -f "${old_rules}" ]]; then
+ case "$(md5sum ${old_rules})" in
+ 2959b3cf61cfe6e466cc3516a7bc19de* | 1e7a7e5d6d28c811eeec98ec26ed5d28* )
+ elog
+ elog "Removing old ${old_rules} ..."
+ rm -f "${old_rules}" ||
+ eerror "Failed, please remove ${old_rules} manually."
+ ;;
+ * )
+ ewarn
+ ewarn "The ${old_rules} file from a previous"
+ ewarn "installation of ${PN} is overriding ${P}'s"
+ ewarn "udev rules. Unless you had deliberately customized it,"
+ ewarn "you should remove it."
+ ewarn
+ ;;
+ esac
+ fi
+
+ linux-mod_pkg_postinst
+}