summaryrefslogtreecommitdiff
path: root/sys-fs/traydevice/traydevice-1.6.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-fs/traydevice/traydevice-1.6.2-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-fs/traydevice/traydevice-1.6.2-r1.ebuild')
-rw-r--r--sys-fs/traydevice/traydevice-1.6.2-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-fs/traydevice/traydevice-1.6.2-r1.ebuild b/sys-fs/traydevice/traydevice-1.6.2-r1.ebuild
new file mode 100644
index 000000000000..da259161112d
--- /dev/null
+++ b/sys-fs/traydevice/traydevice-1.6.2-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python2_7 )
+inherit distutils-r1
+
+DESCRIPTION="A little desktop application displaying systray icon for UDisks"
+HOMEPAGE="https://savannah.nongnu.org/projects/traydevice/"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ sys-fs/udisks:2"
+DEPEND="app-text/docbook2X"
+
+src_compile() { :; }
+
+python_install() {
+ distutils-r1_python_install \
+ --prefix=/usr \
+ --install-data=/usr/share/${PN} \
+ --install-man=/usr/share/man \
+ --docbook2man=docbook2man.pl
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ rm -f "${ED}"/usr/share/${PN}/doc/*.txt
+}