summaryrefslogtreecommitdiff
path: root/sys-fs/tmsu/tmsu-0.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-15 17:13:45 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-15 17:13:45 +0000
commite2d84e38284aeb9d522a7e935554340ddf0e4a6f (patch)
tree5a7444ee5f2af59431481999f729676090b1e0f3 /sys-fs/tmsu/tmsu-0.7.0.ebuild
parent519e4d5d99fc43d5c9a038098c029dc4ef9d6792 (diff)
gentoo resync : 15.11.2017
Diffstat (limited to 'sys-fs/tmsu/tmsu-0.7.0.ebuild')
-rw-r--r--sys-fs/tmsu/tmsu-0.7.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-fs/tmsu/tmsu-0.7.0.ebuild b/sys-fs/tmsu/tmsu-0.7.0.ebuild
new file mode 100644
index 000000000000..d37b33711282
--- /dev/null
+++ b/sys-fs/tmsu/tmsu-0.7.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit golang-build
+
+EGO_PN="github.com/oniony/TMSU/"
+DESCRIPTION="Files tagger and virtual tag-based filesystem"
+HOMEPAGE="https://github.com/oniony/TMSU/wiki"
+SRC_URI="https://github.com/oniony/TMSU/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test zsh-completion"
+
+RDEPEND="
+ zsh-completion? ( app-shells/zsh )
+"
+DEPEND="
+ dev-go/go-sqlite3
+ dev-lang/go
+ dev-libs/go-fuse
+"
+
+src_unpack() {
+ default
+ mv TMSU-${PV} ${P} || die "Failed to move sorce directory."
+}
+
+src_install() {
+ dobin misc/bin/*
+ doman misc/man/tmsu.*
+ newbin TMSU tmsu
+
+ if use zsh-completion ; then
+ insinto /usr/share/zsh/site-functions
+ doins misc/zsh/_tmsu
+ fi
+}