summaryrefslogtreecommitdiff
path: root/sys-fs/static-dev
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-fs/static-dev
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-fs/static-dev')
-rw-r--r--sys-fs/static-dev/Manifest4
-rw-r--r--sys-fs/static-dev/metadata.xml8
-rw-r--r--sys-fs/static-dev/static-dev-0.1.ebuild44
3 files changed, 56 insertions, 0 deletions
diff --git a/sys-fs/static-dev/Manifest b/sys-fs/static-dev/Manifest
new file mode 100644
index 000000000000..3593e023271e
--- /dev/null
+++ b/sys-fs/static-dev/Manifest
@@ -0,0 +1,4 @@
+EBUILD static-dev-0.1.ebuild 1145 SHA256 10f2d53129ba1bfede21bbc30b7125d7fb073f1c4e1fcfa8bc72456302616847 SHA512 74269f4ba717b47878dd695bc9f98325f2ece132f6239f4c3732a35fb00e3e89f8e271e02c4aabeda134a4aae9090ac3f7775c4e609b95108214015cf8f19913 WHIRLPOOL f83fbcbb040ee2fadec958ff29155daf9f109760fa2a0eda634895113f1b389e1d28f36b1e9654e347dcccb222a26418e52785fec58d24ebb1ae7cb5f2fbb1ce
+MISC ChangeLog 3377 SHA256 f5cf7e3bf1c804031d2ebe14f40ae365fe5a5980e2c42d74173094f42652ad80 SHA512 50ccd901c5fb454cc38f6cb0cb4c1b65f2e34c893ba9898c1ff794c78699805b4c67fb9af005db79b4bd7ca8deb9fa322cd5937ca71d266b98e847b8c8f31170 WHIRLPOOL 53510e99474dfa07a2d6fd56581892cb7fd94fa50b8b8e9019eedf2874677c27f30110a46c15c88aba992a3225735cc1d76caa6ef0abc6c4fd5c3812ba27a46e
+MISC ChangeLog-2015 2107 SHA256 b5b150a21d42d5ebe38dccca0755c862fe6affbc98d4e8520bf635ee391e9ca0 SHA512 8a88f9d214ce85ce9179bef3a20f7d55387319a192c775ed8a0165bdc518d224e2812811cab5c556b7a6a6a2ab73ba1fc2fdbffc78788fdd6756ed4aa4320eca WHIRLPOOL 503961c4b6018288c4dd849b49e5e06805a8229f876ab46560670bc964e3e20b504c02929285016e72f3b15f76d4a20902206c106b3f97c4f99742a1430054f2
+MISC metadata.xml 253 SHA256 d82c33ef453113a5c1ebe250dcba373c22934a69b0a86c6ab15a5ca589c25b91 SHA512 54a9069aeb4165d2dff3d473c8001bc51613aac9dff3f7f5e9971a9891a737a31511ffa11cbd523febe581ac1d9de2bdf2f40410f0c4239138f2ccca3ef15555 WHIRLPOOL e5aee23acff864609953a1e4de768f0e4aef704b44c53c021f28573e1ca5c99f1a46d92935ecec2449f7b4419a36d8373127d0ecfa8d7bae72d835e1839eb3f8
diff --git a/sys-fs/static-dev/metadata.xml b/sys-fs/static-dev/metadata.xml
new file mode 100644
index 000000000000..56c124413057
--- /dev/null
+++ b/sys-fs/static-dev/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>base-system@gentoo.org</email>
+ <name>Gentoo Base System</name>
+</maintainer>
+</pkgmetadata>
diff --git a/sys-fs/static-dev/static-dev-0.1.ebuild b/sys-fs/static-dev/static-dev-0.1.ebuild
new file mode 100644
index 000000000000..e7c9cfcf6cbf
--- /dev/null
+++ b/sys-fs/static-dev/static-dev-0.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+DESCRIPTION="A skeleton, statically managed /dev"
+HOMEPAGE="https://bugs.gentoo.org/107875"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
+IUSE=""
+
+RDEPEND="sys-apps/makedev"
+DEPEND="${RDEPEND}"
+
+abort() {
+ echo
+ eerror "We have detected that you currently use udev or devfs or devtmpfs"
+ eerror "and this ebuild cannot install to the same mount-point."
+ die "Cannot install on udev/devfs tmpfs."
+}
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} == "buildonly" ]] ; then
+ # User is just compiling which is fine -- all our checks are merge-time.
+ return
+ fi
+
+ # We want to not clobber udev (tmpfs) or older devfs setups.
+ if [[ -d ${ROOT}/dev/.udev || -c ${ROOT}/dev/.devfs ]] ; then
+ abort
+ fi
+ # We also want to not clobber newer devtmpfs setups.
+ if [[ ${ROOT} == "/" ]] && \
+ ! awk '$2 == "/dev" && $3 == "devtmpfs" { exit 1 }' /proc/mounts ; then
+ abort
+ fi
+}
+
+pkg_postinst() {
+ MAKEDEV -d "${ROOT}"/dev generic sg scd rtc hde hdf hdg hdh input audio video
+}