summaryrefslogtreecommitdiff
path: root/sys-fs/squashfs-tools-ng
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /sys-fs/squashfs-tools-ng
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'sys-fs/squashfs-tools-ng')
-rw-r--r--sys-fs/squashfs-tools-ng/Manifest2
-rw-r--r--sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.1.4.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/sys-fs/squashfs-tools-ng/Manifest b/sys-fs/squashfs-tools-ng/Manifest
index 2b2f565a4a2f..130ad392c34a 100644
--- a/sys-fs/squashfs-tools-ng/Manifest
+++ b/sys-fs/squashfs-tools-ng/Manifest
@@ -1,4 +1,6 @@
DIST squashfs-tools-ng-1.1.3.tar.xz 1181268 BLAKE2B 0d72cc82d937f7403fb67030d799cce37062496bb5dddf68f2151243b99934104e4e576e45bc6bcb2229b1f9eca134482de3180f0035229d829e785fdf0d5d03 SHA512 7a42a540622c324f500e21d64bc57bc203069c6e1deb2624597a767d8267b719bd8f76fbfa0166b7e2d4a6f9acd3d2a46514a45fcb4760052d45c7e1861da94e
+DIST squashfs-tools-ng-1.1.4.tar.xz 1311684 BLAKE2B b976ac223d57919958e0ad04c989e0a9cf2837e1c7ef1e1962069b4796b492fe2fc99c59d1e38b11e380226dc2fc4b2e25e29244635a32d03d0667f2b3ef1d7f SHA512 10e0bebd70de686862f1473588cdbf922ad766c86b64ebd4d6338fd863f862fe0c9374950fa54a197c0f02021c63943cf1ba57ebb7f93a4188e68e2b25b4a800
EBUILD squashfs-tools-ng-1.1.3.ebuild 1129 BLAKE2B aa3e69a031b60b665d6c74b16a0bfc61a327a092a6b9dfa64035fa2fdf2ecc7c3805cd1753b9f2703af02659e7187b9b939011d9a2e0741493f5cedcde56ea30 SHA512 2ccbfe6a31cf89e5a35ca4bd7bc299758464760be4a6de352ee19b5cebec9f564a39f485d64bc1cc2d7435c527e0758fa675d9615d1bd58761a6872c86a90d66
+EBUILD squashfs-tools-ng-1.1.4.ebuild 1129 BLAKE2B ee1639e8ac2ca8bf772da82f6f2763111fc59f2eb3791a865cddd409bf4305a917e99e212fe07ceac587a489d21a15d125ab041619e1c8ce84c58bc549d33132 SHA512 8896b93f2e5e80fbdf32ee320aa3f42eec8859891f474bbe3fc6885c4f1527bcc3abd59331abeff2f7dd61ddca041d421faacab287756a35908122fd6d0ccd33
EBUILD squashfs-tools-ng-9999.ebuild 1129 BLAKE2B aa3e69a031b60b665d6c74b16a0bfc61a327a092a6b9dfa64035fa2fdf2ecc7c3805cd1753b9f2703af02659e7187b9b939011d9a2e0741493f5cedcde56ea30 SHA512 2ccbfe6a31cf89e5a35ca4bd7bc299758464760be4a6de352ee19b5cebec9f564a39f485d64bc1cc2d7435c527e0758fa675d9615d1bd58761a6872c86a90d66
MISC metadata.xml 453 BLAKE2B 4bfc83a611fe2b8da5ce57e56c438c671489d0944cbb4b3f82113bac6bee89028091551c1c96953f166959b087d7e776b28ecb6b9290489f007ea5ca33090ebf SHA512 013b8d87af8c6298eaba48b4aa4282a8781321b0a15d1a8745361e389bb6c5ae6957b24af4bb6b88125cff5f9824b0e878051bd395fdeb98c2ae0ef7f2b370a7
diff --git a/sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.1.4.ebuild b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.1.4.ebuild
new file mode 100644
index 000000000000..46990a47a6dc
--- /dev/null
+++ b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.1.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A new set of tools for working with SquashFS images"
+HOMEPAGE="https://github.com/AgentD/squashfs-tools-ng"
+if [[ ${PV} = 9999* ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/AgentD/${PN}.git"
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ SRC_URI="https://infraroot.at/pub/squashfs/${P}.tar.xz"
+fi
+
+LICENSE="LGPL-3+ tools? ( GPL-3+ )"
+SLOT="0"
+IUSE="lz4 +lzma lzo selinux +tools zstd"
+
+DEPEND="
+ sys-libs/zlib:=
+ lz4? ( app-arch/lz4:= )
+ lzma? ( app-arch/xz-utils:= )
+ lzo? ( dev-libs/lzo:= )
+ selinux? ( sys-libs/libselinux:= )
+ zstd? ( app-arch/zstd:= )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ [[ ${PV} == "9999" ]] && eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --disable-static
+ $(use_with lz4)
+ $(use_with lzo)
+ $(use_with selinux)
+ $(use_with tools)
+ $(use_with lzma xz)
+ $(use_with zstd)
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -delete || die
+}