summaryrefslogtreecommitdiff
path: root/sys-fs/squashfs-tools-ng
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 23:02:44 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 23:02:44 +0100
commitdb063b515939ab15261136b24e4bc44386335c0c (patch)
tree54c06cac96a32ba6fe5f69e52616a2ab27bbb6d6 /sys-fs/squashfs-tools-ng
parent8b4ace9c50842c5b83401ea7b179dcab940387e1 (diff)
gentoo resync : 24.09.2020
Diffstat (limited to 'sys-fs/squashfs-tools-ng')
-rw-r--r--sys-fs/squashfs-tools-ng/Manifest2
-rw-r--r--sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.0.2.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/sys-fs/squashfs-tools-ng/Manifest b/sys-fs/squashfs-tools-ng/Manifest
index 3d42ef817c09..2fe47a0e4e3b 100644
--- a/sys-fs/squashfs-tools-ng/Manifest
+++ b/sys-fs/squashfs-tools-ng/Manifest
@@ -1,4 +1,6 @@
DIST squashfs-tools-ng-1.0.1.tar.xz 1079720 BLAKE2B efc4d715c65d42876d5ac51364d195267c6bc6c2219fea5746231bc4efbd9adac3fa23ea58f837da8610179f3d96ec9422efebe4ae231f4ab243cf948e64fa9b SHA512 3b597b7bf654c6897e04dc6c18cec6034a8f0c0fe070c8d6eb3c8f4a06f4ab2ea8c970ac18c12f05ccb3015cf911790e945798a34361fdb7d1a442a1ca646a04
+DIST squashfs-tools-ng-1.0.2.tar.xz 1085300 BLAKE2B 59331a131bda9b9bae9f162f80abaeb99a6a3ea49958c1d2ce84968d3f010cdf803821a6f2230a173fcd1e7f5224f06b82463b84e31419a7a10a5ede2bee1a61 SHA512 d23d886c7f13046cae8b0e16c380d0c6e681d8921428357f30da9660200332e3dee8b072449c45ab858b0d9fa388d62eb748fb03d6182da6a8839e5ca806176b
EBUILD squashfs-tools-ng-1.0.1.ebuild 1122 BLAKE2B d7dd3c7314464d58d15f6229a52ee3336d853fae9f3238459202f385dbf253906b6a94fd4ea4469ccfd756abe4c504a3a40ad6c1f4442dd41b7b0448d29fde9e SHA512 d4c951eeb931881b710cdddafb381492b1698ac9b86506a73a73b346ace42f4048420bd035fff53a5bfa08bbd7ffcd958f254a4eef24316326c86fb92ae5214a
+EBUILD squashfs-tools-ng-1.0.2.ebuild 1122 BLAKE2B d7dd3c7314464d58d15f6229a52ee3336d853fae9f3238459202f385dbf253906b6a94fd4ea4469ccfd756abe4c504a3a40ad6c1f4442dd41b7b0448d29fde9e SHA512 d4c951eeb931881b710cdddafb381492b1698ac9b86506a73a73b346ace42f4048420bd035fff53a5bfa08bbd7ffcd958f254a4eef24316326c86fb92ae5214a
EBUILD squashfs-tools-ng-9999.ebuild 1117 BLAKE2B b003c6754e392cecbdf7b763c50653b2ed268a03c7005081f8d31f16aff5fdcde5fb4f86e2ebfaca03247c2e33ace848250cffdfc1e66ae8d4de57c15a5c7ae8 SHA512 5b8a6b42f929047fced02ba98a26e1309bce5fd0a1ce9956cd6a21c1061539b56c5d2dc2bd29a24860c9841dab26777ab0e22c8c5968cc6ebd72c3a2962fccd7
MISC metadata.xml 556 BLAKE2B fcff50b7024c1743fb7d7e677c04865bba266c011305d701b4a27b1ce813eb492b6becb64b5f1d4d52a3efd5a80d3369ac88ac65c2665cb0121c6b59d592b966 SHA512 cd1de16571ec7651bf353e804c8f44cbe6a919c21577a832782d8213e7e956b5af1769889eb1631f1a97c44b89018d484122fee59bedef4409363901101df6e3
diff --git a/sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.0.2.ebuild b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.0.2.ebuild
new file mode 100644
index 000000000000..79c567828ddc
--- /dev/null
+++ b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.0.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A new set of tools for working with SquashFS images"
+HOMEPAGE="https://github.com/AgentD/squashfs-tools-ng"
+if [[ ${PV} = 9999* ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/AgentD/${PN}.git"
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ SRC_URI="https://infraroot.at/pub/squashfs/${P}.tar.xz"
+fi
+
+LICENSE="LGPL-3+ tools? ( GPL-3+ )"
+SLOT="0"
+IUSE="lz4 lzo selinux +tools +xz zstd"
+
+DEPEND="
+ sys-libs/zlib:=
+ lz4? ( app-arch/lz4:= )
+ lzo? ( dev-libs/lzo:= )
+ xz? ( app-arch/xz-utils:= )
+ selinux? ( sys-libs/libselinux:= )
+ zstd? ( app-arch/zstd:= )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ [[ ${PV} == "9999" ]] && eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --disable-static
+ $(use_with lz4)
+ $(use_with lzo)
+ $(use_with selinux)
+ $(use_with tools)
+ $(use_with xz)
+ $(use_with zstd)
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -delete || die
+}