summaryrefslogtreecommitdiff
path: root/sys-fs/squashfs-tools-ng
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
commitb24bd25253fe093f722ab576d29fdc41d04cb1ee (patch)
tree0fcf2afd9f852c4d4c291cf8afaa2c244d598105 /sys-fs/squashfs-tools-ng
parent121ed4eec41fbf03e1998d09eede1bf449da63b9 (diff)
gentoo resync : 02.08.2019
Diffstat (limited to 'sys-fs/squashfs-tools-ng')
-rw-r--r--sys-fs/squashfs-tools-ng/Manifest4
-rw-r--r--sys-fs/squashfs-tools-ng/metadata.xml15
-rw-r--r--sys-fs/squashfs-tools-ng/squashfs-tools-ng-0.5.ebuild46
-rw-r--r--sys-fs/squashfs-tools-ng/squashfs-tools-ng-9999.ebuild46
4 files changed, 111 insertions, 0 deletions
diff --git a/sys-fs/squashfs-tools-ng/Manifest b/sys-fs/squashfs-tools-ng/Manifest
new file mode 100644
index 000000000000..fcd9270dc6fe
--- /dev/null
+++ b/sys-fs/squashfs-tools-ng/Manifest
@@ -0,0 +1,4 @@
+DIST squashfs-tools-ng-0.5.tar.xz 158048 BLAKE2B e8d53336a0955875eaf5a301329f620f6efd27d27d985c760a7eaaded94a60e1a7384f076311101b4a6de36b1330d7b42866079b074b6af1829d4162c1f62b38 SHA512 b39cd6e9627e71eb0fcc59a587612fe062c3f437e11342e6ec1a1fee1e6a51b38dcc881bf9a1d69578ad4686f939ece8ec02ed79a6cc6c69afe06bc6753390bf
+EBUILD squashfs-tools-ng-0.5.ebuild 1069 BLAKE2B fe678e7d13fffbaaeb7722b78db10a16d37f38788ac3850b785ad59aed89787cdc9cb6b867549f78532835e269684efaa74aa7ed6d4f6a5fb2ded18cae5fc380 SHA512 d332d401829b10aac7518df6717ee53f0152380a49789d893b489f8b8895fcda4bc76114346caae218403ba5470a8f4696bec8be22454f94b3cc8207f938c047
+EBUILD squashfs-tools-ng-9999.ebuild 1069 BLAKE2B fe678e7d13fffbaaeb7722b78db10a16d37f38788ac3850b785ad59aed89787cdc9cb6b867549f78532835e269684efaa74aa7ed6d4f6a5fb2ded18cae5fc380 SHA512 d332d401829b10aac7518df6717ee53f0152380a49789d893b489f8b8895fcda4bc76114346caae218403ba5470a8f4696bec8be22454f94b3cc8207f938c047
+MISC metadata.xml 545 BLAKE2B 23c96d1109e1a1e89bba2c00bbbd80954b900f6a40aa45a97d29d15aa31ec10ee1020f43013bdfebba29df7cc1dff106ef7f56b65d175953992629edbdbc79c6 SHA512 0de80916d5a7a88a356533ce0194542e5e26792c0c2d0fc0336ac3d0524e1d78c47b2f0870a2c34d886a83ed2017eab2f56edce325c8344c31865a426016d485
diff --git a/sys-fs/squashfs-tools-ng/metadata.xml b/sys-fs/squashfs-tools-ng/metadata.xml
new file mode 100644
index 000000000000..b1a0267dd913
--- /dev/null
+++ b/sys-fs/squashfs-tools-ng/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mattst88@gentoo.org</email>
+ <name>Matt Turner</name>
+ </maintainer>
+ <use>
+ <flag name="lz4">Enable support for LZ4 compression using <pkg>app-arch/lz4</pkg></flag>
+ <flag name="xz">Enable support for XZ ("LZMA2") compression using <pkg>app-arch/xz-utils</pkg></flag>
+ </use>
+ <upstream>
+ <remote-id type="github">AgentD/squashfs-tools-ng</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-fs/squashfs-tools-ng/squashfs-tools-ng-0.5.ebuild b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-0.5.ebuild
new file mode 100644
index 000000000000..fc732972175d
--- /dev/null
+++ b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-0.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A new set of tools for working with SquashFS images"
+HOMEPAGE="https://github.com/AgentD/squashfs-tools-ng"
+if [[ ${PV} = 9999* ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/AgentD/${PN}.git"
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ SRC_URI="https://infraroot.at/pub/squashfs/${P}.tar.xz"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="lz4 lzo selinux +xz +zlib zstd"
+REQUIRED_USE="|| ( lz4 lzo xz zlib zstd )"
+
+DEPEND="
+ lz4? ( app-arch/lz4:= )
+ lzo? ( dev-libs/lzo:= )
+ xz? ( app-arch/xz-utils:= )
+ selinux? ( sys-libs/libselinux:= )
+ zlib? ( sys-libs/zlib:= )
+ zstd? ( app-arch/zstd:= )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ [[ ${PV} == "9999" ]] && eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ $(use_with lz4)
+ $(use_with lzo)
+ $(use_with selinux)
+ $(use_with xz)
+ $(use_with zlib gzip)
+ $(use_with zstd)
+ )
+ econf "${myconf[@]}"
+}
diff --git a/sys-fs/squashfs-tools-ng/squashfs-tools-ng-9999.ebuild b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-9999.ebuild
new file mode 100644
index 000000000000..fc732972175d
--- /dev/null
+++ b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A new set of tools for working with SquashFS images"
+HOMEPAGE="https://github.com/AgentD/squashfs-tools-ng"
+if [[ ${PV} = 9999* ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/AgentD/${PN}.git"
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ SRC_URI="https://infraroot.at/pub/squashfs/${P}.tar.xz"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="lz4 lzo selinux +xz +zlib zstd"
+REQUIRED_USE="|| ( lz4 lzo xz zlib zstd )"
+
+DEPEND="
+ lz4? ( app-arch/lz4:= )
+ lzo? ( dev-libs/lzo:= )
+ xz? ( app-arch/xz-utils:= )
+ selinux? ( sys-libs/libselinux:= )
+ zlib? ( sys-libs/zlib:= )
+ zstd? ( app-arch/zstd:= )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ [[ ${PV} == "9999" ]] && eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ $(use_with lz4)
+ $(use_with lzo)
+ $(use_with selinux)
+ $(use_with xz)
+ $(use_with zlib gzip)
+ $(use_with zstd)
+ )
+ econf "${myconf[@]}"
+}