summaryrefslogtreecommitdiff
path: root/sys-fs/squashfs-tools-ng
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /sys-fs/squashfs-tools-ng
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'sys-fs/squashfs-tools-ng')
-rw-r--r--sys-fs/squashfs-tools-ng/Manifest2
-rw-r--r--sys-fs/squashfs-tools-ng/squashfs-tools-ng-0.8.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/sys-fs/squashfs-tools-ng/Manifest b/sys-fs/squashfs-tools-ng/Manifest
index 9e9a010da8c3..84f0c0f6ab39 100644
--- a/sys-fs/squashfs-tools-ng/Manifest
+++ b/sys-fs/squashfs-tools-ng/Manifest
@@ -1,4 +1,6 @@
DIST squashfs-tools-ng-0.7.tar.xz 372956 BLAKE2B 5fd0849c8cb0255ea56edc5b5cdc771363f5ca038f4306bb7d816ff26ce23cbd4f4652ef8ae497b8c9fe1ec09f9ebcfcf13aeb6b99b97db80a95018c25d4a3a6 SHA512 e53d7b64e68a40b49667b65d9fa8f12e977e8ca923c2fe9ce1e1def2745573f8607f7dee7ae6c06496489ef721c4c500ec40513ea5f6bd3ad4bb3a7796972b8e
+DIST squashfs-tools-ng-0.8.tar.xz 1004616 BLAKE2B 5d347eef252886e7750da306f038494a15660350aca7b93aaf85a8411882489d8855c771e719a68b025f5c15fdc8b0d30727dde0884c5982460ff85d106fcd37 SHA512 7a533c7f9f21f717718a9ce5d775cf297c2e8edb6f121741b14692b52cbb6e3d7fe5cd59525222f7f9617440ea2adb2acec4dda3252abf3bebc689905b9fdc20
EBUILD squashfs-tools-ng-0.7.ebuild 1117 BLAKE2B b003c6754e392cecbdf7b763c50653b2ed268a03c7005081f8d31f16aff5fdcde5fb4f86e2ebfaca03247c2e33ace848250cffdfc1e66ae8d4de57c15a5c7ae8 SHA512 5b8a6b42f929047fced02ba98a26e1309bce5fd0a1ce9956cd6a21c1061539b56c5d2dc2bd29a24860c9841dab26777ab0e22c8c5968cc6ebd72c3a2962fccd7
+EBUILD squashfs-tools-ng-0.8.ebuild 1117 BLAKE2B b003c6754e392cecbdf7b763c50653b2ed268a03c7005081f8d31f16aff5fdcde5fb4f86e2ebfaca03247c2e33ace848250cffdfc1e66ae8d4de57c15a5c7ae8 SHA512 5b8a6b42f929047fced02ba98a26e1309bce5fd0a1ce9956cd6a21c1061539b56c5d2dc2bd29a24860c9841dab26777ab0e22c8c5968cc6ebd72c3a2962fccd7
EBUILD squashfs-tools-ng-9999.ebuild 1117 BLAKE2B b003c6754e392cecbdf7b763c50653b2ed268a03c7005081f8d31f16aff5fdcde5fb4f86e2ebfaca03247c2e33ace848250cffdfc1e66ae8d4de57c15a5c7ae8 SHA512 5b8a6b42f929047fced02ba98a26e1309bce5fd0a1ce9956cd6a21c1061539b56c5d2dc2bd29a24860c9841dab26777ab0e22c8c5968cc6ebd72c3a2962fccd7
MISC metadata.xml 556 BLAKE2B fcff50b7024c1743fb7d7e677c04865bba266c011305d701b4a27b1ce813eb492b6becb64b5f1d4d52a3efd5a80d3369ac88ac65c2665cb0121c6b59d592b966 SHA512 cd1de16571ec7651bf353e804c8f44cbe6a919c21577a832782d8213e7e956b5af1769889eb1631f1a97c44b89018d484122fee59bedef4409363901101df6e3
diff --git a/sys-fs/squashfs-tools-ng/squashfs-tools-ng-0.8.ebuild b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-0.8.ebuild
new file mode 100644
index 000000000000..22a2dbc93b62
--- /dev/null
+++ b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-0.8.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A new set of tools for working with SquashFS images"
+HOMEPAGE="https://github.com/AgentD/squashfs-tools-ng"
+if [[ ${PV} = 9999* ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/AgentD/${PN}.git"
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ SRC_URI="https://infraroot.at/pub/squashfs/${P}.tar.xz"
+fi
+
+LICENSE="LGPL-3+ tools? ( GPL-3+ )"
+SLOT="0"
+IUSE="lz4 lzo selinux +tools +xz zstd"
+
+DEPEND="
+ sys-libs/zlib:=
+ lz4? ( app-arch/lz4:= )
+ lzo? ( dev-libs/lzo:= )
+ xz? ( app-arch/xz-utils:= )
+ selinux? ( sys-libs/libselinux:= )
+ zstd? ( app-arch/zstd:= )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ [[ ${PV} == "9999" ]] && eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --disable-static
+ $(use_with lz4)
+ $(use_with lzo)
+ $(use_with selinux)
+ $(use_with tools)
+ $(use_with xz)
+ $(use_with zstd)
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -delete || die
+}