summaryrefslogtreecommitdiff
path: root/sys-fs/squashfs-tools-ng
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
commit185fa19bbf68a4d4dca534d2b46729207a177f16 (patch)
treea8a537b82fda83a0799c2ca9887f212558363aa7 /sys-fs/squashfs-tools-ng
parentc8fd0d84af0bfd1949542adc2cbb735b1d28f9ed (diff)
gentoo resync : 11.05.2021
Diffstat (limited to 'sys-fs/squashfs-tools-ng')
-rw-r--r--sys-fs/squashfs-tools-ng/Manifest2
-rw-r--r--sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.1.1.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/sys-fs/squashfs-tools-ng/Manifest b/sys-fs/squashfs-tools-ng/Manifest
index 1452fec6b280..23e07111cdac 100644
--- a/sys-fs/squashfs-tools-ng/Manifest
+++ b/sys-fs/squashfs-tools-ng/Manifest
@@ -1,4 +1,6 @@
DIST squashfs-tools-ng-1.1.0.tar.xz 1169556 BLAKE2B 87222e87176a69aef39130af9e6d9b23d9e2f81e10680eb26236260ebe50dedcfbba33785d739a98a152825e535d0d166f7ce08262157341a6ef48d1d2ef33e0 SHA512 06b76fb8bb4295ac451bc98cbe757b272ac831c2ec146803b4813b9792486372691864fcaaa1a3cac6628608ac62cf081f1aa331c0802ea1a9858461fef33923
+DIST squashfs-tools-ng-1.1.1.tar.xz 1170232 BLAKE2B 8224b59f70c3c02df3762024510c75a038f8d9f1853575ccfa527173a528f17bd68ae4ec1d2448563aa504f683f5d9152cb07545db6b965f36a224dc95841f17 SHA512 2a7aa689b49fe06ec77e9b9c3bdcf264d05a478aa08543d8e8bc22ef45f10f351b49706485ed93cbd5adc537cd066f94e70952867838ec51859e8f6ce34607f4
EBUILD squashfs-tools-ng-1.1.0.ebuild 1117 BLAKE2B b003c6754e392cecbdf7b763c50653b2ed268a03c7005081f8d31f16aff5fdcde5fb4f86e2ebfaca03247c2e33ace848250cffdfc1e66ae8d4de57c15a5c7ae8 SHA512 5b8a6b42f929047fced02ba98a26e1309bce5fd0a1ce9956cd6a21c1061539b56c5d2dc2bd29a24860c9841dab26777ab0e22c8c5968cc6ebd72c3a2962fccd7
+EBUILD squashfs-tools-ng-1.1.1.ebuild 1117 BLAKE2B b003c6754e392cecbdf7b763c50653b2ed268a03c7005081f8d31f16aff5fdcde5fb4f86e2ebfaca03247c2e33ace848250cffdfc1e66ae8d4de57c15a5c7ae8 SHA512 5b8a6b42f929047fced02ba98a26e1309bce5fd0a1ce9956cd6a21c1061539b56c5d2dc2bd29a24860c9841dab26777ab0e22c8c5968cc6ebd72c3a2962fccd7
EBUILD squashfs-tools-ng-9999.ebuild 1117 BLAKE2B b003c6754e392cecbdf7b763c50653b2ed268a03c7005081f8d31f16aff5fdcde5fb4f86e2ebfaca03247c2e33ace848250cffdfc1e66ae8d4de57c15a5c7ae8 SHA512 5b8a6b42f929047fced02ba98a26e1309bce5fd0a1ce9956cd6a21c1061539b56c5d2dc2bd29a24860c9841dab26777ab0e22c8c5968cc6ebd72c3a2962fccd7
MISC metadata.xml 556 BLAKE2B fcff50b7024c1743fb7d7e677c04865bba266c011305d701b4a27b1ce813eb492b6becb64b5f1d4d52a3efd5a80d3369ac88ac65c2665cb0121c6b59d592b966 SHA512 cd1de16571ec7651bf353e804c8f44cbe6a919c21577a832782d8213e7e956b5af1769889eb1631f1a97c44b89018d484122fee59bedef4409363901101df6e3
diff --git a/sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.1.1.ebuild b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.1.1.ebuild
new file mode 100644
index 000000000000..22a2dbc93b62
--- /dev/null
+++ b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.1.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A new set of tools for working with SquashFS images"
+HOMEPAGE="https://github.com/AgentD/squashfs-tools-ng"
+if [[ ${PV} = 9999* ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/AgentD/${PN}.git"
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ SRC_URI="https://infraroot.at/pub/squashfs/${P}.tar.xz"
+fi
+
+LICENSE="LGPL-3+ tools? ( GPL-3+ )"
+SLOT="0"
+IUSE="lz4 lzo selinux +tools +xz zstd"
+
+DEPEND="
+ sys-libs/zlib:=
+ lz4? ( app-arch/lz4:= )
+ lzo? ( dev-libs/lzo:= )
+ xz? ( app-arch/xz-utils:= )
+ selinux? ( sys-libs/libselinux:= )
+ zstd? ( app-arch/zstd:= )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ [[ ${PV} == "9999" ]] && eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --disable-static
+ $(use_with lz4)
+ $(use_with lzo)
+ $(use_with selinux)
+ $(use_with tools)
+ $(use_with xz)
+ $(use_with zstd)
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -delete || die
+}