summaryrefslogtreecommitdiff
path: root/sys-fs/quota/quota-4.04-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /sys-fs/quota/quota-4.04-r2.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'sys-fs/quota/quota-4.04-r2.ebuild')
-rw-r--r--sys-fs/quota/quota-4.04-r2.ebuild83
1 files changed, 0 insertions, 83 deletions
diff --git a/sys-fs/quota/quota-4.04-r2.ebuild b/sys-fs/quota/quota-4.04-r2.ebuild
deleted file mode 100644
index 1d128be85e60..000000000000
--- a/sys-fs/quota/quota-4.04-r2.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools
-
-DESCRIPTION="Linux quota tools"
-HOMEPAGE="https://sourceforge.net/projects/linuxquota/"
-SRC_URI="mirror://sourceforge/linuxquota/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ~mips ppc ppc64 sparc x86"
-IUSE="ldap netlink nls rpc tcpd"
-
-RDEPEND="
- sys-fs/e2fsprogs
- ldap? ( >=net-nds/openldap-2.3.35 )
- netlink? (
- sys-apps/dbus
- dev-libs/libnl:3
- )
- rpc? (
- net-nds/rpcbind
- elibc_glibc? ( sys-libs/glibc[-rpc(-)] )
- net-libs/libtirpc
- net-libs/rpcsvc-proto
- )
- tcpd? ( sys-apps/tcp-wrappers )
-"
-DEPEND="
- ${RDEPEND}
- nls? ( sys-devel/gettext )
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-glibc226.patch"
- "${FILESDIR}/${P}-Listen-on-a-TCP-socket.patch"
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --enable-ext2direct
- $(use_enable nls)
- $(use_enable ldap ldapmail)
- $(use_enable netlink)
- $(use_enable rpc)
- $(use_enable rpc rpcsetquota)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc doc/* README.* Changelog
-
- insinto /etc
- insopts -m0644
- doins warnquota.conf quotatab
-
- newinitd "${FILESDIR}"/quota.rc7 quota
- newconfd "${FILESDIR}"/quota.confd quota
-
- if use rpc ; then
- newinitd "${FILESDIR}"/rpc.rquotad.initd rpc.rquotad
- fi
-
- if use ldap ; then
- insinto /etc/openldap/schema
- insopts -m0644
- doins "${FILESDIR}"/ldap-scripts/quota.schema
-
- exeinto /usr/share/quota/ldap-scripts
- doexe "${FILESDIR}"/ldap-scripts/*.pl
- doexe "${FILESDIR}"/ldap-scripts/edquota_editor
- fi
-}