summaryrefslogtreecommitdiff
path: root/sys-fs/multipath-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-01 20:53:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-01 20:53:45 +0000
commit896d6a8a88861c42b5d531a2f147c8a29a149bd8 (patch)
tree081fe10813721a96088dca6b54bc35bcac18afc6 /sys-fs/multipath-tools
parent3059f20995d5ac642b7b4a38d538fdf1cc45d90d (diff)
gentoo auto-resync : 01:12:2022 - 20:53:45
Diffstat (limited to 'sys-fs/multipath-tools')
-rw-r--r--sys-fs/multipath-tools/Manifest1
-rw-r--r--sys-fs/multipath-tools/multipath-tools-0.9.3-r2.ebuild97
2 files changed, 98 insertions, 0 deletions
diff --git a/sys-fs/multipath-tools/Manifest b/sys-fs/multipath-tools/Manifest
index 581872ce333d..6bb7eee76c4b 100644
--- a/sys-fs/multipath-tools/Manifest
+++ b/sys-fs/multipath-tools/Manifest
@@ -7,5 +7,6 @@ DIST multipath-tools-0.9.0.tar.gz 537311 BLAKE2B e7d4958d24d1e19da2b80be23585ad3
DIST multipath-tools-0.9.3.tar.gz 552442 BLAKE2B e2065119cdd68bd8c2b4420bd0de9ce370601597972dba32c076bfc4df6d0a1a65356454a2f96f95f27cf681387685edcbac2eb41258d4a7049a1ef62cdf0949 SHA512 4faa2ee5a96a9d5d752219931ebc885cb70ed6b022d45ede985ad7919c043a3aee166e6f126d32dffd187c5c32d5cbce91747d87d0b55557e2f7f68b279583da
EBUILD multipath-tools-0.8.9.ebuild 2091 BLAKE2B e6fa02e23e152cb1eb730ecf3f8714d75aa391daf48f8a55350780d711ef7239a6dd2aeda1dd4ede09024cdbe4f12d61b22be3d00094482a24318ecc2f1147de SHA512 9aa9722d0fd8927c09b4f1a631f5bdbc2a14d8bdf72fdbfe53da3a74cd7f6a7623d098534fb093e236d694c1a5594d611ffbc94879a4ecd6e046d823bb7830eb
EBUILD multipath-tools-0.9.0.ebuild 1759 BLAKE2B b988f5cc90eb8e8b9d61154e1cdc901fca42a94bd2aef6fd7b999d25d666b43e09611b01a39dc757bb167b04428821225004d3d3dfb85d2e233aba6d246b6b77 SHA512 2849e1ee2e649dea2fa18a9cdd73da06ae6ff28babdd127a122f9a81c416be83f48eeb9556b90e11ba53489b5023e80e2d37e65618fdadb45f07024431e9f5a9
+EBUILD multipath-tools-0.9.3-r2.ebuild 2430 BLAKE2B 0fe03de138073d8c9c053ddc448c05f0dea199d3e03227b35e5ebdf981e88339d48598a2fef32ef191919a423550110a0f7f9c1426a5281e36339e71cdef290e SHA512 5c487f27bc81de3a1b8d43b03e3b765ff39406751649b7917bed3d92370667025d93d7f32171bb953cb18fe712345c2faed120b846fd8053fa21df893a980189
EBUILD multipath-tools-0.9.3.ebuild 2328 BLAKE2B ff73af2f67386d163fd94f3f88ae4b299b447b95ee7449a860ea9e791305f92c7d41fa64d42d1633464c4322bc0491f5cff9024ca13a1bb7f62e990471c70d5c SHA512 a8d5572055b6d4883bd142b0288f034c4e6b3beb4c8c47b8c55d00c8e1d7d11dcf4802e5c8a63eef46d4d158ae49fb73ee35353d1207d029481a6da539615e68
MISC metadata.xml 453 BLAKE2B 2f2a56731716bfb47dee061219c80834aa382daf9e6ce937cef2237fc1bbb05e988672cc178ad471d68e9ab4f9292677be71ef9198a163f85a7f3b8658f5d698 SHA512 e8df3db70f5d919789ff0512409365fc80dfbb31ede6079c49910e8acffc6b5289290a48acef8230bc59899262801255048d1a730f81c3642945f8c872ac5428
diff --git a/sys-fs/multipath-tools/multipath-tools-0.9.3-r2.ebuild b/sys-fs/multipath-tools/multipath-tools-0.9.3-r2.ebuild
new file mode 100644
index 000000000000..ff744e92c05d
--- /dev/null
+++ b/sys-fs/multipath-tools/multipath-tools-0.9.3-r2.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info systemd toolchain-funcs udev tmpfiles
+
+DESCRIPTION="Device mapper target autoconfig"
+HOMEPAGE="http://christophe.varoqui.free.fr/"
+SRC_URI="https://github.com/opensvc/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ~loong ppc ppc64 ~riscv x86"
+IUSE="systemd test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/json-c:=
+ dev-libs/libaio
+ dev-libs/userspace-rcu:=
+ >=sys-fs/lvm2-2.02.45
+ >=virtual/libudev-232-r3
+ sys-libs/readline:=
+ systemd? ( sys-apps/systemd )"
+DEPEND="${RDEPEND}
+ test? ( dev-util/cmocka )"
+BDEPEND="virtual/pkgconfig"
+
+CONFIG_CHECK="~DM_MULTIPATH"
+
+src_prepare() {
+ default
+
+ sed -r -i -e '/^(CPPFLAGS|CFLAGS)\>/s,^(CPPFLAGS|CFLAGS)\>[[:space:]]+:=,\1 := $(GENTOO_\1),' \
+ "${S}"/Makefile.inc || die
+}
+
+src_compile() {
+ tc-export CC
+
+ # LIBDM_API_FLUSH involves grepping files in /usr/include,
+ # so force the test to go the way we want #411337.
+ emake \
+ prefix="${EPREFIX}/usr" \
+ plugindir="${EPREFIX}/$(get_libdir)/multipath" \
+ LIB="$(get_libdir)" \
+ LIBDM_API_FLUSH=1 \
+ PKGCONFIG="$(tc-getPKG_CONFIG)" \
+ GENTOO_CFLAGS="${CFLAGS}" \
+ GENTOO_CPPFLAGS="${CPPFLAGS}" \
+ FAKEVAR=1
+}
+
+src_install() {
+ dodir /sbin
+
+ # Please clean this up > 0.9.3: https://github.com/opensvc/multipath-tools/pull/53
+ # $(prefix) doesn't work correctly in makefile in 0.9.3.
+ emake \
+ DESTDIR="${ED}" \
+ prefix="${EPREFIX}" \
+ LIB="$(get_libdir)" \
+ RUN=run \
+ plugindir="${EPREFIX}/$(get_libdir)/multipath" \
+ unitdir="$(systemd_get_systemunitdir)" \
+ libudevdir="${EPREFIX}/$(get_udevdir)" \
+ pkgconfdir="${EPREFIX}/usr/$(get_libdir)/pkgconfig" \
+ GENTOO_CFLAGS="${CFLAGS}" \
+ GENTOO_CPPFLAGS="${CPPFLAGS}" \
+ install
+
+ rmdir "${ED}"/usr/include
+ rmdir "${ED}"/usr/share
+ mv "${ED}"/include "${ED}"/usr/include || die
+ mv "${ED}"/share "${ED}"/usr/share || die
+ einstalldocs
+
+ newinitd "${FILESDIR}"/multipathd-r1.rc multipathd
+ newinitd "${FILESDIR}"/multipath.rc multipath
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ tmpfiles_process /usr/lib/tmpfiles.d/multipath.conf
+ udev_reload
+
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "If you need multipath on your system, you must"
+ elog "add 'multipath' into your boot runlevel!"
+ fi
+}
+
+pkg_postrm() {
+ udev_reload
+}