summaryrefslogtreecommitdiff
path: root/sys-fs/multipath-tools/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-23 12:45:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-23 12:45:14 +0000
commitc8c3804588db08dae281504dd79ef71741cd8dc3 (patch)
treec0dc730627dd25f276c533a00e6b763b8eef1f56 /sys-fs/multipath-tools/files
parentdd5b71d2ad69f1887985ee1ca67b254e04157f73 (diff)
gentoo auto-resync : 23:03:2023 - 12:45:13
Diffstat (limited to 'sys-fs/multipath-tools/files')
-rw-r--r--sys-fs/multipath-tools/files/multipath-tools-0.9.4-test-fix.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-fs/multipath-tools/files/multipath-tools-0.9.4-test-fix.patch b/sys-fs/multipath-tools/files/multipath-tools-0.9.4-test-fix.patch
new file mode 100644
index 000000000000..c0469a20d122
--- /dev/null
+++ b/sys-fs/multipath-tools/files/multipath-tools-0.9.4-test-fix.patch
@@ -0,0 +1,31 @@
+https://listman.redhat.com/archives/dm-devel/2023-March/053587.html
+
+From 2ebbff587e80f3f153b934d3cfcccb8a4bb21568 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Thu, 23 Mar 2023 08:04:49 +0000
+Subject: [PATCH] tests: fix quoting of CFLAGS in Makefile
+
+Otherwise, when CFLAGS/CPPFLAGS have multiple entries (like "-O2 -pipe"), we
+get an error:
+```
+make[1]: Entering directory '/var/tmp/portage/sys-fs/multipath-tools-0.9.4/work/multipath-tools-0.9.4/tests'
+/bin/sh: line 1: -pipe: command not found
+make[1]: *** [Makefile:115: libmultipath.so.0] Error 127
+make[1]: *** Waiting for unfinished jobs....
+```
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/tests/Makefile
++++ b/tests/Makefile
+@@ -112,7 +112,7 @@ dep_clean:
+ # Pass the original values of CFLAGS etc. to the sub-make, which will include
+ # Makefile.in again. Otherwise, the flags would be added twice.
+ libmultipath.so.0: $(multipathdir)/libmultipath.so.0
+- @CFLAGS=$(ORIG_CFLAGS) CPPFLAGS=$(ORIG_CPPFLAGS) LDFLAGS=$(ORIG_LDFLAGS) \
++ @CFLAGS="$(ORIG_CFLAGS)" CPPFLAGS="$(ORIG_CPPFLAGS)" LDFLAGS="$(ORIG_LDFLAGS)" \
+ $(MAKE) -C $(multipathdir) configdir=$(TESTDIR)/conf.d plugindir=$(TESTDIR)/lib test-lib
+
+ # COLON will get expanded during second expansion below
+--
+2.40.0
+