summaryrefslogtreecommitdiff
path: root/sys-fs/mtpfs/mtpfs-1.1-r5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
commitc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (patch)
tree9ea78393bc3ecd6ab4de449383d4e97e5f3648ae /sys-fs/mtpfs/mtpfs-1.1-r5.ebuild
parent2891d29af8907ce881662f4a02844926d7a293c7 (diff)
gentoo resync : 12.01.2019
Diffstat (limited to 'sys-fs/mtpfs/mtpfs-1.1-r5.ebuild')
-rw-r--r--sys-fs/mtpfs/mtpfs-1.1-r5.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/sys-fs/mtpfs/mtpfs-1.1-r5.ebuild b/sys-fs/mtpfs/mtpfs-1.1-r5.ebuild
new file mode 100644
index 000000000000..8cc52ebc9b74
--- /dev/null
+++ b/sys-fs/mtpfs/mtpfs-1.1-r5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A FUSE filesystem providing access to MTP devices"
+HOMEPAGE="https://www.adebenham.com/mtpfs/"
+SRC_URI="https://www.adebenham.com/files/mtp/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug mad"
+
+RDEPEND="dev-libs/glib:2
+ >=media-libs/libmtp-1.1.2
+ <sys-fs/fuse-3:0=
+ mad? (
+ media-libs/libid3tag
+ media-libs/libmad
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=(AUTHORS NEWS README)
+
+PATCHES=( "${FILESDIR}"/${P}-fix-mutex-crash.patch
+ "${FILESDIR}"/${P}-unitialized-variable.patch
+ "${FILESDIR}"/${P}-wking-patches/
+ "${FILESDIR}"/${P}-g_printf.patch )
+
+src_prepare() {
+ default
+ sed -e "/#include <string.h>/ a\
+ #include <stdlib.h>" -i mtpfs.h id3read.c || die #implicit
+}
+
+src_configure() {
+ econf $(use_enable debug) \
+ $(use_enable mad)
+}
+
+pkg_postinst() {
+ einfo "To mount your MTP device, issue:"
+ einfo " /usr/bin/mtpfs <mountpoint>"
+ echo
+ einfo "To unmount your MTP device, issue:"
+ einfo " /usr/bin/fusermount -u <mountpoint>"
+
+ if use debug; then
+ echo
+ einfo "You have enabled debugging output."
+ einfo "Please make sure you run mtpfs with the -d flag."
+ fi
+}