summaryrefslogtreecommitdiff
path: root/sys-fs/mtd-utils/mtd-utils-1.5.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-fs/mtd-utils/mtd-utils-1.5.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-fs/mtd-utils/mtd-utils-1.5.2.ebuild')
-rw-r--r--sys-fs/mtd-utils/mtd-utils-1.5.2.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/sys-fs/mtd-utils/mtd-utils-1.5.2.ebuild b/sys-fs/mtd-utils/mtd-utils-1.5.2.ebuild
new file mode 100644
index 000000000000..3aff08116584
--- /dev/null
+++ b/sys-fs/mtd-utils/mtd-utils-1.5.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils vcs-snapshot
+
+if [[ ${PV} == "99999999" ]] ; then
+ EGIT_REPO_URI="git://git.infradead.org/mtd-utils.git"
+
+ inherit git-2
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ if [[ ${PV} == *.*.* ]] ; then
+ MY_PV="${PV}-*"
+ SRC_URI="http://git.infradead.org/mtd-utils.git/snapshot/v${PV}.tar.gz -> ${P}.tar.gz"
+ else
+ MY_PV="${PV}-02ae0aac87576d07202a62d11294ea55b56f450b"
+ SRC_URI="mirror://gentoo/${PN}-snapshot-${MY_PV}.tar.xz"
+ fi
+ KEYWORDS="amd64 arm ~mips ppc x86 ~amd64-linux ~arm-linux ~x86-linux"
+fi
+
+DESCRIPTION="MTD userspace tools (NFTL, JFFS2, NAND, FTL, UBI)"
+HOMEPAGE="http://git.infradead.org/?p=mtd-utils.git;a=summary"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="xattr"
+
+# We need libuuid
+RDEPEND="!sys-fs/mtd
+ dev-libs/lzo
+ sys-libs/zlib
+ >=sys-apps/util-linux-2.16"
+# ACL is only required for the <sys/acl.h> header file to build mkfs.jffs2
+# And ACL brings in Attr as well.
+DEPEND="${RDEPEND}
+ xattr? ( sys-apps/acl )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-sysmacros.patch #580206
+}
+
+makeopts() {
+ # These affect build output, so keep it common between compile & install.
+ echo CROSS=${CHOST}- V=1
+ use xattr || echo WITHOUT_XATTR=1
+}
+
+src_compile() {
+ tc-export AR CC RANLIB
+ local compileopts=(
+ AR="${AR}" CC="${CC}" RANLIB="${RANLIB}"
+ )
+ emake $(makeopts) "${compileopts[@]}"
+}
+
+src_install() {
+ emake $(makeopts) install DESTDIR="${ED}"
+ dodoc *.txt
+ newdoc mkfs.ubifs/README README.mkfs.ubifs
+ # TODO: check ubi-utils for docs+scripts
+}