summaryrefslogtreecommitdiff
path: root/sys-fs/lxcfs/lxcfs-4.0.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /sys-fs/lxcfs/lxcfs-4.0.9.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'sys-fs/lxcfs/lxcfs-4.0.9.ebuild')
-rw-r--r--sys-fs/lxcfs/lxcfs-4.0.9.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/sys-fs/lxcfs/lxcfs-4.0.9.ebuild b/sys-fs/lxcfs/lxcfs-4.0.9.ebuild
deleted file mode 100644
index 92a99fe69f2a..000000000000
--- a/sys-fs/lxcfs/lxcfs-4.0.9.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools systemd verify-sig
-
-DESCRIPTION="FUSE filesystem for LXC"
-HOMEPAGE="https://linuxcontainers.org/lxcfs/introduction/ https://github.com/lxc/lxcfs/"
-SRC_URI="https://linuxcontainers.org/downloads/lxcfs/${P}.tar.gz
- verify-sig? ( https://linuxcontainers.org/downloads/lxcfs/${P}.tar.gz.asc )"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~riscv ~x86"
-
-RDEPEND="dev-libs/glib:2
- sys-fs/fuse:3"
-DEPEND="${RDEPEND}"
-BDEPEND="sys-apps/help2man
- verify-sig? ( app-crypt/openpgp-keys-linuxcontainers )"
-
-# Test files need to be updated to fuse:3, #764620
-RESTRICT="test"
-
-VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/linuxcontainers.asc
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- # Without the localstatedir the filesystem isn't mounted correctly
- # Without with-distro ./configure will fail when cross-compiling
- econf --localstatedir=/var --with-distro=gentoo --disable-static
-}
-
-src_test() {
- cd tests/ || die
- emake tests
- ./main.sh || die "Tests failed"
-}
-
-src_install() {
- default
-
- newconfd "${FILESDIR}"/lxcfs-4.0.0.confd lxcfs
- newinitd "${FILESDIR}"/lxcfs-4.0.0.initd lxcfs
-
- # Provide our own service file (copy of upstream) due to paths being different from upstream,
- # #728470
- systemd_newunit "${FILESDIR}"/lxcfs-4.0.0.service lxcfs.service
-
- find "${ED}" -name '*.la' -delete || die
-}