summaryrefslogtreecommitdiff
path: root/sys-fs/inotify-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-fs/inotify-tools
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-fs/inotify-tools')
-rw-r--r--sys-fs/inotify-tools/Manifest5
-rw-r--r--sys-fs/inotify-tools/inotify-tools-3.14.ebuild34
-rw-r--r--sys-fs/inotify-tools/metadata.xml17
3 files changed, 56 insertions, 0 deletions
diff --git a/sys-fs/inotify-tools/Manifest b/sys-fs/inotify-tools/Manifest
new file mode 100644
index 000000000000..5dea4a2fd863
--- /dev/null
+++ b/sys-fs/inotify-tools/Manifest
@@ -0,0 +1,5 @@
+DIST inotify-tools-3.14.tar.gz 358772 SHA256 222bcca8893d7bf8a1ce207fb39ceead5233b5015623d099392e95197676c92f SHA512 6074d510e89bba5da0d7c4d86f2562c662868666ba0a7ea5d73e53c010a0050dd1fc01959b22cffdb9b8a35bd1b0b43c04d02d6f19927520f05889e8a9297dfb WHIRLPOOL fb22537b127ed8c03f4d0501d498c3731d7b85ce688ab8f281c7173d615c876d9ccd77b1d5a2a4effed642cfa30a99738b751608c9f279ce627ae951b41cada4
+EBUILD inotify-tools-3.14.ebuild 793 SHA256 372e32cf88e24adb3744fd1bf67dd8c36049d1683a50a799f29457130efeb59f SHA512 316279c93f1277e74547a4e728847353e11068bcc0fd2fc26b988d9b9c2c0029ac1c7d5e14a0c64eb526312c7e70c1364c2763835402863838987533a39b7044 WHIRLPOOL ecb0ec29d21742ad75d2c51cb1cdb624d1a2a88a1df4dee51bd6fd5507497ced96842028955efc76ab21d261eb3d3fa158d825a3a9f11c55c2b36177799001f9
+MISC ChangeLog 3393 SHA256 9528ff0f255618e38a6ae4b422a600493f5f9978587ec10943b5c59f4704fae7 SHA512 b11ba1b3ccea2f1f29462c9855cc422d9d6a6aee7ce5c5855e51263b9306f5b3117bce8b6b41d6f11265536c17565f58aa0e05c4d9b112ce08892b5c691fa763 WHIRLPOOL 4fb8c558bb107e48f00c4554c423f4c4988f4a6374f6f154ba6726592569a19ac84c6103e5a8940d519bc7ea9ebf262fdab95501606a323695db1d1410aba476
+MISC ChangeLog-2015 5740 SHA256 1c7563bc600decda3cce873910f4fbe1cd46763ad5ece40e7bebb4c96b4228b6 SHA512 c072cd2a4304b3bce2e71c244ff81eaffaf0ead41aaa449e0db62e2df1f7729325a1df5005753b7b9e4f075462d9dff2519af9a9b95bd3e65cc421e5661f8f8e WHIRLPOOL 7ef6f19f6523b99a5c2da103e7f438a9a79c024521ccaa1fffcb4952c21c40df80e0b660544111372b565513cd557933a788613dad627368331bacc9ef59b3a9
+MISC metadata.xml 649 SHA256 794c3971508bcbe9e7cdc5727b1f7f486aa05d0529824f08644c811e1fff103f SHA512 62eaab525f91d97a37b526fb07b7ee4b5c7abcfdd9f785655d3252de2a4f545649da51341c5c0ff4201e0ea097bb7206d2dbe5285c9008a392c55e4802c229e7 WHIRLPOOL 3f5fb5ade49fbd9f4c4c4c66b3af2a859b4967c738ae11f333539b217c2d8c0ae2066df68ada16bd054a628da66a7ac0916705f7d955c429666f18d8daea666f
diff --git a/sys-fs/inotify-tools/inotify-tools-3.14.ebuild b/sys-fs/inotify-tools/inotify-tools-3.14.ebuild
new file mode 100644
index 000000000000..8db9c3ff722f
--- /dev/null
+++ b/sys-fs/inotify-tools/inotify-tools-3.14.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="a set of command-line programs providing a simple interface to inotify"
+HOMEPAGE="https://github.com/rvoicilas/inotify-tools/wiki"
+SRC_URI="mirror://github/rvoicilas/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm hppa ~mips ~sparc x86"
+IUSE="doc"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+src_prepare() {
+ default
+ # timestamps are busted in tarball
+ find . -type f -exec touch -r configure {} +
+}
+
+src_configure() {
+ # only docs installed are doxygen ones, so use /html
+ econf \
+ --docdir='$(datarootdir)'/doc/${PF}/html \
+ $(use_enable doc doxygen)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README NEWS AUTHORS ChangeLog
+}
diff --git a/sys-fs/inotify-tools/metadata.xml b/sys-fs/inotify-tools/metadata.xml
new file mode 100644
index 000000000000..b385aee8e3b2
--- /dev/null
+++ b/sys-fs/inotify-tools/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>polynomial-c@gentoo.org</email>
+ <name>Lars Wendler</name>
+ </maintainer>
+ <longdescription>
+inotify-tools is a set of command-line programs for Linux providing a simple
+interface to inotify. These programs can be used to monitor and act upon
+filesystem events. Requires a Linux kernel supporting inotify.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">rvoicilas/inotify-tools</remote-id>
+ <remote-id type="sourceforge">inotify-tools</remote-id>
+ </upstream>
+</pkgmetadata>