summaryrefslogtreecommitdiff
path: root/sys-fs/inotify-tools/inotify-tools-3.20.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-10 05:25:01 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-10 05:25:01 +0000
commit456dbeaab3e2f71f527eae542ab44d1e372b0655 (patch)
tree5cee708ec6e4b4e530a4337e7389598dc7cd6144 /sys-fs/inotify-tools/inotify-tools-3.20.1.ebuild
parent65737cf14a7220bd9a487aa2af4ae0e79bd23e86 (diff)
gentoo resync : 10.01.2018
Diffstat (limited to 'sys-fs/inotify-tools/inotify-tools-3.20.1.ebuild')
-rw-r--r--sys-fs/inotify-tools/inotify-tools-3.20.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-fs/inotify-tools/inotify-tools-3.20.1.ebuild b/sys-fs/inotify-tools/inotify-tools-3.20.1.ebuild
new file mode 100644
index 000000000000..9f5d0f02a1c8
--- /dev/null
+++ b/sys-fs/inotify-tools/inotify-tools-3.20.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="a set of command-line programs providing a simple interface to inotify"
+HOMEPAGE="https://github.com/rvoicilas/inotify-tools/wiki"
+SRC_URI="https://github.com/rvoicilas/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # only docs installed are doxygen ones, so use /html
+ local myeconfargs=(
+ --docdir='$(datarootdir)'/doc/${PF}/html
+ $(use_enable doc doxygen)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED%/}" \( -name '*.a*' -o -name '*.la' \) -delete || die
+}