summaryrefslogtreecommitdiff
path: root/sys-fs/fatsort
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
commit71deace00d1a2b091313fe137ab7092418c6f87c (patch)
tree9f1f0dee23e13658e52f49437befe78427148c51 /sys-fs/fatsort
parent29aabba0ea759c6a2864ff5631735b67ee38e5e0 (diff)
gentoo resync : 10.02.2020
Diffstat (limited to 'sys-fs/fatsort')
-rw-r--r--sys-fs/fatsort/Manifest2
-rw-r--r--sys-fs/fatsort/fatsort-1.6.2.605.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/sys-fs/fatsort/Manifest b/sys-fs/fatsort/Manifest
index ff90877cdaf9..9745a11e2d6d 100644
--- a/sys-fs/fatsort/Manifest
+++ b/sys-fs/fatsort/Manifest
@@ -1,3 +1,5 @@
DIST fatsort-1.5.0.456.tar.xz 56100 BLAKE2B 996f144c67a2311ef9962b06e776d0a0c8897814383e50c9f48f5af0bc800159ee34c10d9f8d51dae5160844dfe9fcbc4b56bb9883cbdb0402a0ea20198fc1d6 SHA512 fe9d8108494fd64da730ec40882582fc16a89e76a5ba4e8040d03a3dbbf12c525904abe24814337713f5f1d15c72e8321b27fad69db816c073a96fbfd15ea486
+DIST fatsort-1.6.2.605.tar.xz 122928 BLAKE2B 2690233828e47a4809aac14a8d64dc8d95a824bec52f787190186adbe066d5d4e6f9c6d1873fc6b809c6df6879d12154430f44d412944963bdff49e673079d12 SHA512 0d119c99c5efff4c10367152fc6efe95e2cb1c39405ca02dd25b66cc68c7420b5b28c0daca1346b7928633bac8ace2d05d731502f989d39ca5c783dcec69ccc7
EBUILD fatsort-1.5.0.ebuild 791 BLAKE2B 1a7977e9e5ccaa82997389e928ad9c0cfa20b52cb5b832ee10a2bb230a7df565eb2ab58701312a01c69a11ad80d6dc8371ae97b62a8da89b5d74eb3e286f7c15 SHA512 ab728f5bf316680d9443ce345819062132d802bcd38c451a8efb21a761f86ceb4d1f7e217242bcce44d7580750b38a919f97b4ca7847eb37c260d32db7e09537
+EBUILD fatsort-1.6.2.605.ebuild 711 BLAKE2B 32f6849c788b83476c2388097eb14169e56b8b30381d388dc63c74cce6ac15696934f581ad6dbc397c4b0e08ea98b5cced46cac5c3cf447387b67b7d5f8b271d SHA512 f25a251ff55fedf93c2e7d81ac5416dec9c3cd66b3087bb7212e3c2f328783b08b690ca0ea56dd170936806cf198d6ac5a5883b1b1aefa8569f54ee1df042f8e
MISC metadata.xml 738 BLAKE2B b4ae8042af9b7a74705b42322ffcfba47aa18e3cb1bee693ff2db3fecb6555d516ec9a3f4746643ef37007e9d1b44ea79d5fa0e4bc12b6ca4ba813129d208dcd SHA512 42cb5be41b29129b17ea55591d352872ccd6078705068c6899d4f1f5a5b99ab5f6809e75ee6b49bd6b536f6b66632ce9e1859f4bbad764b966d5520a8aa5a228
diff --git a/sys-fs/fatsort/fatsort-1.6.2.605.ebuild b/sys-fs/fatsort/fatsort-1.6.2.605.ebuild
new file mode 100644
index 000000000000..e80f5c53a7f4
--- /dev/null
+++ b/sys-fs/fatsort/fatsort-1.6.2.605.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Sorts files on FAT16/32 partitions, ideal for basic audio players"
+HOMEPAGE="http://fatsort.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ default
+
+ sed -i -e 's|/usr/local|/usr|g' \
+ $(find ./ -name Makefile) || die
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) LD=$(tc-getCC) \
+ CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ DESTDIR="${D}"
+}
+
+src_test() {
+ # Tests require root permissions and mounting filesystems which does
+ # not work inside the ebuild environment
+ true
+}