summaryrefslogtreecommitdiff
path: root/sys-fs/fatsort
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /sys-fs/fatsort
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'sys-fs/fatsort')
-rw-r--r--sys-fs/fatsort/Manifest2
-rw-r--r--sys-fs/fatsort/fatsort-1.6.3.622.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/sys-fs/fatsort/Manifest b/sys-fs/fatsort/Manifest
index 944a7385579a..49a2fd01a092 100644
--- a/sys-fs/fatsort/Manifest
+++ b/sys-fs/fatsort/Manifest
@@ -1,4 +1,6 @@
AUX fatsort-1.6.2.605-gcc10.patch 7400 BLAKE2B 05d9f3bc9c0118c9505e96f2766d27b142a61252f5ad21e3c106ac7afda9a69bddc1ec1dbb9f3b170bbc10315f04db06e80000ef0eb9c601db4b5b88da82e08a SHA512 bac23d94900f48f8fd331962f617b92250ff9cfc801a688526177ef24e571e341e124a2859cbf1ff8db80d1bcbb32ee99d1c9878abcdaa78b9dd0606f5689e28
DIST fatsort-1.6.2.605.tar.xz 122928 BLAKE2B 2690233828e47a4809aac14a8d64dc8d95a824bec52f787190186adbe066d5d4e6f9c6d1873fc6b809c6df6879d12154430f44d412944963bdff49e673079d12 SHA512 0d119c99c5efff4c10367152fc6efe95e2cb1c39405ca02dd25b66cc68c7420b5b28c0daca1346b7928633bac8ace2d05d731502f989d39ca5c783dcec69ccc7
+DIST fatsort-1.6.3.622.tar.xz 123644 BLAKE2B 1db530753bdaee4ebda9ab36a47f6794584bc590de4cbf8d144a5baa770c080c9d27a1ecadd5a22de72538887c4e10f161f3c4fb3afb3e63bd18834897ebe905 SHA512 309c7424e53fb74f57d0c4272a1a4b3df57fa1130d7e7adae0ac73ac1c8b1900504e49efd0cc4dafea3efa2fbc9191f343b10bb97b647dd6124197356cd01c53
EBUILD fatsort-1.6.2.605.ebuild 754 BLAKE2B 11850d6ad2ca62de3f7c110773fa216a5d5cf1b7df81e2fc8eaa81fae2e9f029f4ee7b40ddcd5a66991a98d5bbb35e48b9328591aa6ce93e2f305da588d98d6a SHA512 cc94184f60f4ed2c17a476c4ed0718caae60db2769129233b82f39c5d0d9eb41eed803377c1b38bcb6db3b720937f85f5e659ed51fccb2e5bb72b0562d7c9202
+EBUILD fatsort-1.6.3.622.ebuild 715 BLAKE2B d41dd107dc97485ba7d7225703dc813d81acb112fab52551d4360015873c806bbdee4b909fe180228db695a0493bd0d3a7b49bdcec4cd85006727d63af98ffce SHA512 764a8bff79153356dcea1c8fb746f5cc43af397441e114b4d92806769ee22e2a3f6d65f8ccd4445f1e7ffbc011681fc5a7004163776da6ae7abb1d3096f2cd8d
MISC metadata.xml 738 BLAKE2B b4ae8042af9b7a74705b42322ffcfba47aa18e3cb1bee693ff2db3fecb6555d516ec9a3f4746643ef37007e9d1b44ea79d5fa0e4bc12b6ca4ba813129d208dcd SHA512 42cb5be41b29129b17ea55591d352872ccd6078705068c6899d4f1f5a5b99ab5f6809e75ee6b49bd6b536f6b66632ce9e1859f4bbad764b966d5520a8aa5a228
diff --git a/sys-fs/fatsort/fatsort-1.6.3.622.ebuild b/sys-fs/fatsort/fatsort-1.6.3.622.ebuild
new file mode 100644
index 000000000000..28d6fc9100bc
--- /dev/null
+++ b/sys-fs/fatsort/fatsort-1.6.3.622.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Sorts files on FAT16/32 partitions, ideal for basic audio players"
+HOMEPAGE="http://fatsort.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ default
+
+ sed -i -e 's|/usr/local|/usr|g' \
+ $(find ./ -name Makefile) || die
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) LD=$(tc-getCC) \
+ CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ DESTDIR="${D}" man
+}
+
+src_test() {
+ # Tests require root permissions and mounting filesystems which does
+ # not work inside the ebuild environment
+ true
+}