summaryrefslogtreecommitdiff
path: root/sys-fs/fatcat/fatcat-1.1.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /sys-fs/fatcat/fatcat-1.1.0-r1.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'sys-fs/fatcat/fatcat-1.1.0-r1.ebuild')
-rw-r--r--sys-fs/fatcat/fatcat-1.1.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-fs/fatcat/fatcat-1.1.0-r1.ebuild b/sys-fs/fatcat/fatcat-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..3fd6f3130447
--- /dev/null
+++ b/sys-fs/fatcat/fatcat-1.1.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2018-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="FAT filesystems explore, extract, repair, and forensic tool"
+HOMEPAGE="https://github.com/Gregwar/fatcat"
+SRC_URI="https://github.com/Gregwar/fatcat/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="!elibc_glibc? ( sys-libs/argp-standalone )"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/fatcat-include-getopt.patch )
+
+src_install() {
+ cmake-utils_src_install
+ doman man/${PN}.1
+ dodoc docs/*.md
+}