summaryrefslogtreecommitdiff
path: root/sys-fs/erofs-utils/erofs-utils-1.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-16 11:57:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-16 11:57:19 +0000
commit61f62e5edc868fc4ae3b92af397397ee5056578a (patch)
tree81261ca75a34aa85973eeb3cd828878c4e72bcee /sys-fs/erofs-utils/erofs-utils-1.5-r1.ebuild
parent433cb2e828d414c74b16d429f40d25e179b0a70f (diff)
gentoo auto-resync : 16:01:2023 - 11:57:19
Diffstat (limited to 'sys-fs/erofs-utils/erofs-utils-1.5-r1.ebuild')
-rw-r--r--sys-fs/erofs-utils/erofs-utils-1.5-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-fs/erofs-utils/erofs-utils-1.5-r1.ebuild b/sys-fs/erofs-utils/erofs-utils-1.5-r1.ebuild
new file mode 100644
index 000000000000..bae100e2e3a3
--- /dev/null
+++ b/sys-fs/erofs-utils/erofs-utils-1.5-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Userspace tools for EROFS"
+HOMEPAGE="https://git.kernel.org/pub/scm/linux/kernel/git/xiang/erofs-utils.git"
+LICENSE="GPL-2+"
+
+SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/xiang/${PN}.git/snapshot/${P}.tar.gz"
+KEYWORDS="~amd64 ~loong"
+
+SLOT="0"
+IUSE="fuse +lz4 +lzma selinux +uuid"
+
+RDEPEND="
+ fuse? ( sys-fs/fuse:0 )
+ lz4? ( app-arch/lz4:0= )
+ lzma? ( >=app-arch/xz-utils-5.4.0:0= )
+ selinux? ( sys-libs/libselinux:0= )
+ uuid? ( sys-apps/util-linux )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-werror
+ $(use_enable fuse)
+ $(use_enable lz4)
+ $(use_enable lzma)
+ $(use_with selinux)
+ $(use_with uuid)
+ )
+
+ econf "${myeconfargs[@]}"
+}