summaryrefslogtreecommitdiff
path: root/sys-fs/duf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-04 12:06:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-04 12:06:28 +0000
commit4551b41523452c0d743a71cca34e4dca2ca7538c (patch)
tree2b9ae4a442d7c2810f92833363fd36db073888f0 /sys-fs/duf
parent27e5574c9ed56a2633e25f7fa8f591554266a1b4 (diff)
gentoo auto-resync : 04:01:2023 - 12:06:28
Diffstat (limited to 'sys-fs/duf')
-rw-r--r--sys-fs/duf/Manifest4
-rw-r--r--sys-fs/duf/duf-0.8.1.ebuild27
-rw-r--r--sys-fs/duf/metadata.xml24
3 files changed, 55 insertions, 0 deletions
diff --git a/sys-fs/duf/Manifest b/sys-fs/duf/Manifest
new file mode 100644
index 000000000000..ce7b6ecec7c7
--- /dev/null
+++ b/sys-fs/duf/Manifest
@@ -0,0 +1,4 @@
+DIST duf-0.8.1-deps.tar.xz 6372212 BLAKE2B 01baf089f6142759ef8e376b352e31ecd482f0a94106a4e2606c2f6146cdd7ec33b431621dd680876650896f9d590a21d242b871777164af588e35804a11477e SHA512 51b966b5a8701c8e39ea2d022ca6ee1e0c64fd189b3531d8d0e253d46ee2b5d7270963c3a4930e964312085914edac45c78ed8fa440b459df13977c83ab3c964
+DIST duf-0.8.1.tar.gz 138214 BLAKE2B 388b7494ae15bdc026303ec81f529c08c66e34a8fb82d13c9b7fa730b1684edee5711497d866cbd16376573a386ef9311288e7e9d6143a577d2381425f8218bc SHA512 598318cd90e8a27bdc448cb84682f3846baa02bab0f527a26de42b8b3efd3ba258a76b6f7a74a41405e20b23ccff92db1b6ef7d3412fc8261942a8ccde4241dc
+EBUILD duf-0.8.1.ebuild 613 BLAKE2B 83cf70dd011bccd2e467e984155614594e7b47c62b7f3bff7f7420a9b06b05a6cb83d4fb2a8ceeacd92fe6ccd86c96f3bd6f5743705bb55a0a40c709047b5018 SHA512 a174b7dc51eb40d2478c265717408e07c0803d388e0f1673f1f254d525f2164207723e90753e6edb985c668aca12a508942513ad252a877b24acec0c9607b3fb
+MISC metadata.xml 767 BLAKE2B e6612eda8c95561b5bdc9f75ce9059cd557c0e56ade957968235fbb3917bf5a1d0cb1f1daf2e20b0a41e0490555f0f33ef25333ccfb87ed41b77d6bc3963c963 SHA512 bb56a029fb0f82f0cbecb4181bfd3cd67b51188795441b3e702906644b7da10e929018a77740825a5c68e781e0711446a06480ecb3ffb745edb885cb2e277eac
diff --git a/sys-fs/duf/duf-0.8.1.ebuild b/sys-fs/duf/duf-0.8.1.ebuild
new file mode 100644
index 000000000000..d948b7dff84d
--- /dev/null
+++ b/sys-fs/duf/duf-0.8.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Disk Usage/Free Utility - a better 'df' alternative"
+HOMEPAGE="https://github.com/muesli/duf"
+SRC_URI="https://github.com/muesli/duf/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://github.com/mrmagic223325/duf/releases/download/${PV}/${P}-deps.tar.xz"
+
+LICENSE="MIT BSD Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="pie"
+
+src_compile() {
+ use pie && GOFLAGS+=" -buildmode=pie"
+ ego build
+}
+
+src_install() {
+ dobin duf
+ dodoc README.md
+ doman duf.1
+}
diff --git a/sys-fs/duf/metadata.xml b/sys-fs/duf/metadata.xml
new file mode 100644
index 000000000000..a154ef85f53a
--- /dev/null
+++ b/sys-fs/duf/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>mrmagic223325@fedora.email</email>
+ <name>Mathis Winterer</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <name>Christian Muehlhaeuser</name>
+ </maintainer>
+ <bugs-to>https://github.com/muesli/duf/issues</bugs-to>
+ <doc>https://github.com/muesli/duf</doc>
+ <remote-id type="github">muesli/duf</remote-id>
+ </upstream>
+</pkgmetadata>