summaryrefslogtreecommitdiff
path: root/sys-fs/dosfstools/dosfstools-4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /sys-fs/dosfstools/dosfstools-4.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'sys-fs/dosfstools/dosfstools-4.1.ebuild')
-rw-r--r--sys-fs/dosfstools/dosfstools-4.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-fs/dosfstools/dosfstools-4.1.ebuild b/sys-fs/dosfstools/dosfstools-4.1.ebuild
new file mode 100644
index 000000000000..36848b2cec2b
--- /dev/null
+++ b/sys-fs/dosfstools/dosfstools-4.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="DOS filesystem tools - provides mkdosfs, mkfs.msdos, mkfs.vfat"
+HOMEPAGE="https://github.com/dosfstools/dosfstools"
+SRC_URI="https://github.com/dosfstools/dosfstools/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="compat test +udev"
+
+CDEPEND="udev? ( virtual/libudev )"
+DEPEND="${CDEPEND}
+ test? ( app-editors/vim-core )
+ udev? ( virtual/pkgconfig )"
+RDEPEND="${CDEPEND}"
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ $(use_enable compat compat-symlinks) \
+ $(use_with udev)
+}
+
+src_install() {
+ default
+ if ! use compat; then
+ # Keep fsck -t vfat and mkfs -t vfat working, bug 584980.
+ dosym fsck.fat /usr/sbin/fsck.vfat
+ dosym mkfs.fat /usr/sbin/mkfs.vfat
+ fi
+}